It's all about the answers!

Ask a question

Can anyone offer help installing RTC P2 into Eclipse on RedHat Linux?


Jamie Berry (14013079) | asked Jan 08 '18, 1:15 p.m.

 I have a group of users attempting to install RTC 6.0.4 into Eclipse Neon version 4.6.2 on a RedHat Linux machine.  They are receiving a dependency error for teh International Components for Unicode for JAVA (ICU4J) where there is already an ICU installed, version 4.2.1.v20100412, but the RTC plugin has a dependency for ICU version 56.1.0.v201601250100.  The install is complaining that both of these ICUs can't be installed at the same time.


We are puzzled as the users are attempting to do the installs on Virtual Machines that are created identically.  One user has been able to get 6.0.4 installed while another is running into this issue.

Does anyone know how to resolve this conflict?

Thanks,
Jamie.


Comments
Donald Nong commented Jan 24 '18, 1:33 a.m.

I wonder why an ICU 4.2.1.v20100412 has been installed. When I check the plain zip version of RTC 6.0.4 client, this particular ICU comes in with the SCM tool, while RTC itself uses 4.4.2.v20110823. If I'm not mistaken, ICU 56.1.0.v201601250100 comes with Eclipse Neo, not RTC. So I have no idea why you got such problem in your environment.

One answer



permanent link
Chris Daly (61651) | answered Jan 30 '18, 5:29 p.m.
JAZZ DEVELOPER

Can you try the p2 repo from RTC 6.0.5? 

The reason I suggest this is in 6.0.5 we changed how the p2 repo is built.  In 6.0.4 and older, it was built with pieces of Eclipse 3.6 (the com.ibm.icu_4.2.1.v20100412.jar is from the Eclipse 3.6 era).

In 6.0.5 the p2 repo is build with Eclipse 4.2 era stuff.  This is still pretty old, but it might make a difference (because you are using Eclipse 4.6, so this would at least mean both parts are composed of Eclipse 4.x plugins).  I looked at the 6.0.5 p2 repo and I see this version:  com.ibm.icu_4.4.2.v20110823.jar, which is newer, but nothing like the 56.1.0.v201601250100 version, so this still might not work but I think it is worth a try.


Comments
Jamie Berry commented Jan 30 '18, 5:31 p.m.

 Our Server is running 6.0.4, so wouldn't we run into a version mismatch error?


Thanks for the information though.  It is something to keep in mind when we do upgrade to 6.0.5.


Chris Daly commented Jan 30 '18, 5:36 p.m.
JAZZ DEVELOPER

yes, I think the client version has to be equal to, or older than the server version, so you would need to wait until your server goes to 6.0.5 to try this.

Your answer


Register or to post your answer.