It's all about the answers!

Ask a question

Can anyone help with an RQM Execute offline issue?


0
1
Jamie Berry (14013994) | asked Sep 08 '17, 10:25 a.m.
retagged Sep 15 '17, 6:26 a.m. by Minakshi Jaint (5113)

We are using RQM 6.0.3 with the 32-bit Excel RQM Importer utility to attempt execution of test cases offline.  The RQM importer works fine for importing test cases and scripts, did that first. However, when I attempted to run a test case with a manual test script offline, I ran into problems.  I was able to Import the .rqms file into Excel and update the spreadsheet with my results.  The issue came about when I tried to import my results back into the Repository.  I received the following output:

Initializing.....
Reading Configuration File....
Getting artifacts from document - "OfflineData_JLB01.xls".....
Sending artifacts to https://gdqm01.gddsi.com:9443/qm.....
Sending executionresult 0 named urn:com.ibm.rqm:executionresult:46290...
Error sending to server urn:com.ibm.rqm:executionresult:46290 of type executionresult
The remote server returned an error: (400) Bad Request.

Exporting completed with 1 failures!

Detailed log file at: C:\Users\p57733\AppData\Roaming\Mso2Rqm\131493518303862509 log.txt

I have tried this with 2 different test cases. Has anyone seen this issue before and know what is going on?  I thought I would check here before submitting a PMR.

Thanks,

Jamie.

Accepted answer


permanent link
Don Yang (7.7k21110139) | answered Sep 25 '17, 2:07 a.m.

This seems to be a defect in RQM:
https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=150066

which was resolved in v6.0.3. I think you may want to try ExcelImporter 6.0.3 or even v6.0.4 ExcelImporter(preferred as it has other fixes added to 6.0.4)

Jamie Berry selected this answer as the correct answer

2 other answers



permanent link
abhishek gour (3812) | answered Sep 12 '17, 2:45 a.m.

Hi Jamie, 

The error which you are getting in importing results back in to RQM database via Excel Importer Utility could be very specific to the spreadsheet ( the .xls file ) you are trying to import. The .xls file structure may not be as per Utility Configuration file.

Ideally the excel spreadsheet which is generated from .rqms should not be changed for other than filling in the results for each test step. If there is any changes in the spreadsheet other than just filling in the results then the import of results may not be successful. 
I hope the version of RQM Excel importer is compatible with RQM 6.0.3 which you are using. 

Thanks,
Abhishek


Comments
Jamie Berry commented Sep 12 '17, 10:33 a.m.

 Abhishek,


Thank you for the response.  I checked and I am actually using the 6.0.2 version of the Excel Importer.  I have not made any changes to the spreadsheet other than put in a status.  I have submitted a PMR with all my files to try and get help on the issue.

Thank you,
Jamie.


permanent link
abhishek gour (3812) | answered Sep 12 '17, 2:47 a.m.

 Also - I hope you have gone through this link to know where any mistake might have been happening - https://jazz.net/help-dev/clm/index.jsp?topic=%2Fcom.ibm.rational.test.qm.doc%2Ftopics%2Ft_run_offline.html

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.