It's all about the answers!

Ask a question

Unable to attach files or links to execution results of test case


Amit Garg (311525) | asked Jun 03 '13, 8:46 a.m.
retagged Jun 03 '13, 2:35 p.m. by Laura Kuczarski (21137)

I'm using RQM 4.0.2 command line adapter. Whenever I try to attach any doc/text file or add a link to the execution results of the test case, I get the following warning message:

http://www.google.com" is not an existing file nor a valid URI link.  Unable to
associate with execution result.
ExitCode: 0
C:\Documents and Settings\username\My Documents\sample.txt" is not an existing fil
e nor a valid URI link.  Unable to associate with execution result.

I'm following the steps mentioned in http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/index.jsp?topic=%2Fcom.ibm.rational.test.qm.doc%2Ftopics%2Ft_add_cmd_line_attachments.html

Accepted answer


permanent link
Thomas Neal (14133) | answered Jun 03 '13, 1:54 p.m.
JAZZ DEVELOPER
Hello Amit, I'm guessing the double-quotes are being passed through into the properties file.  So the result ends up looking something like this.

"mylink=http://www.google.com"
"myfile=C:\Documents and Settings\username\My Documents\sample.txt"

This would result in properties with names "mylink and "myfile, with values http://www.google.com" and C:\Documents and Settings\username\My Documents\sample.txt".  Try removing the quotes in your echo commands (assuming you're using echo).  One other thing you'll need to address is to either escape the backslash characters in the path or use forward slashes, ie. C:/Documents and Settings/username/My Documents/sample.txt

I hope this helps!
Amit Garg selected this answer as the correct answer

Comments
Laura Kuczarski commented Jun 03 '13, 2:34 p.m.
JAZZ DEVELOPER

Hello,
I also submitted a documentation defect to update the example in the help topic and remove the quotes: https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=88424


Amit Garg commented Jun 04 '13, 3:36 a.m.

Thanks a lot Thomas. Removing the double quotes did the trick and yes I am using the forward slashes.

However it is strange that before I raised this question, I was not using the double quotes and it was still throwing some errors.

Your answer


Register or to post your answer.