It's all about the answers!

Ask a question

Why is the upgrade to 6.0.3 forcing me to use ojdbc7.jar driver. We are still using Oracle 11g


Michael Johnson (4416) | asked Aug 14 '17, 11:18 a.m.

 All, 

I started to upgrade RTC v6.0.1 to RTC v6.0.3.  
I am on Windows 2012 Server WAS 8.5.5.11 with an Oracle database (11.0.2.4).   I am using the upgrade scripts.  The first script that I run (repotools -upgrade jts)  errors out that the oracle driver is incorrect and can't be found.  

The error states that the Oracle Driver (ojdbc7.jar) cannot be found at C:\IBM\JTS603\server\conf\oracle.  

I installed 6.0.1 with no problem with the oracle driver (ojdbc6.jar) located at:
C:\IBM\oracle\ojdbc6.jar.  This is also the property that is set in WAS (ORACLE_JDBC_DRIVER_FILE).  

Documentation reads that I should be using ojdbc6.jar (Oracle v 11g). 
Can I simply put the ojdbc7.jar where it wants it?  Why don't I have control over this?  Where are these properties set?

Thanks for your help!
Michael

One answer



permanent link
Michael Johnson (4416) | answered Aug 14 '17, 7:13 p.m.

All,

Once I found the ojdbc7.jar driver and moved it to the location specified in the error:

C:\IBM\JTS603\server\conf\oracle

I was able to successfully run all of the upgrade scripts with out error.  I find it odd that the documentation clearly states we are supposed to use the ojdbc6.jar driver - we could not continue with the upgrade without the newer Oracle driver.

So my answer is - go ahead and use the newer driver - it worked fine for us.

Good luck,

Michael

Your answer


Register or to post your answer.