It's all about the answers!

Ask a question

RTC 6.0.2 - GIT integration: the right steps to do


Alberto Teodoro (6631631) | asked Feb 13 '17, 1:01 p.m.

Hi all.

I'm trying to set the integration between RTC 6.0.2 and GIT.
I'm following the steps in the official guide: 
  1.  in the first step, Installing and configuring Rational Team Concert and Git using an Apache HTTP server (https://www.ibm.com/support/knowledgecenter/en/SSYMRC_6.0.2/com.ibm.team.connector.cq.doc/topics/t_git_install.html), I've found the whole list of tools and SW to install.
  2. In the following step Configuring Git server-side hooks (https://www.ibm.com/support/knowledgecenter/en/SSYMRC_6.0.2/com.ibm.team.connector.cq.doc/topics/t_git_hooks.html) I've found another pre-requisite to satisfy: I have to install also NodeJS v0.12.0.
Now I don't understand if I can avoid to use NodeJS or not: sorry but the guide it's (for me) not very clear.
Then, if I need to install NodeJS v0.12.0, I have the problem that I can't find an official rpm for my RHEL 5.9 and the distro required (v0.12) encountered compiling errors (both using python 2.2 and python 3.4).
I can't use sudo yum install nodejs npm (or via apt-get) because the server is in a protected net, not open to Internet.
Please, someone can advice me how to go on?
Many thanks in advance
Alberto

Accepted answer


permanent link
Lily Wang (4.9k714) | answered Feb 13 '17, 6:26 p.m.

To setup Git and RTC integration, you need to deploy Git on web server. So you can either use Apache HTTP server or NodeJS server.


To setup Git on NodeJS, you can follow the step-by-step document:
The document https://jazz.net/wiki/bin/view/Main/RTCGitNodeJSServer provides NodeJS distribution list.

If you want to deploy Git on Apache HTTP server, you do not need to install Node JS. You can refer to the article https://jazz.net/library/article/1426.

Alberto Teodoro selected this answer as the correct answer

Comments
Alberto Teodoro commented Feb 14 '17, 5:39 a.m.
Please! Let me know if I've correctly understood: if Ia use NodeJS, I have not to use httpd server?
My GIT installation use httpd server: now I can switch of it and use only NodeJS?
Ciao
Alberto

Alberto Teodoro commented Feb 14 '17, 5:57 a.m.

I've started Nodejs: I use only Nodejs and no httpd server.

But now I've anymore the authorization that I've set (with blood and sweat!) on httpd configuration.
I can I set the authorized users on Nodejs conf? Into the conf.json? How?
Many thanks in advance.
Alberto
   

2 other answers



permanent link
Alberto Teodoro (6631631) | answered Feb 14 '17, 3:48 a.m.

Hi Lily many tahnks for your answres.

In the official guide the steps of Apache and Nodejs (for me) seem to be mixed.
However, finally I was able to install NodeJS v0.12.0 (using Phyton 2.7).
Now I have all configured as described in the wiki page Node JS Server for RTC-Git Integration (https://jazz.net/wiki/bin/view/Main/RTCGitNodeJSServer#ScopeIn601), and, after the editing of config.jason, the in the server.log I've found "Invalid Config file at /opt/rtc-git-server-toolkit/server/config.json. Exiting application".
I'm pretty sure I've well configured config.jason: where I can find some written examples?
Many thanks in advance.
Alberto



Comments
Alberto Teodoro commented Feb 14 '17, 5:53 a.m.

I have set up correctly my config.jason

Now I have the Error: listen EADDRINUSE
Probably beacause I use the port 80, already used by the httpd server for GIT.
Please! Let me know: if Ia use NodeJS, I have not to use httpd server?
Ciao
Alberto



Alberto Teodoro commented Feb 14 '17, 5:54 a.m.

I've resolved the Nodejs strt: I use only Nodejs and no httpd server  


Lily Wang commented Feb 14 '17, 7:09 p.m.

If you are running Git on Node JS, you don't need to use HTTP server.
For the Node JS authentication, I suggest you use LDAP. If you use "BASIC" as the wiki https://jazz.net/wiki/bin/view/Main/RTCGitIntegrationSetupUsingNode, you need to change CLM authentication from FORM to BASIC.
Please let me know if you have further issue.


Alberto Teodoro commented Feb 15 '17, 2:05 a.m.

Hi Lily,

Thank you.
I've simply tried now using the authentication BASIC, because I've tried with the LDAP, but probably some attributes it's not correct in the Json sintax.
I've thougth that, using BASIC authentication, I shuold be able to push the git changes to master: instead the address for the master it's now not found.
At the same address, before, by using httpd server (on another port, now) I was able to make the push.
I've used almost the same dir three of the example, but I've the git (.git) repos nested into 2 level dirs.
Maybe the Json property value for "Git-Repositories-Root-Dir", in SO Linux, should be written in a different way: in the example I see a dir under Winodows SO. I used insted "/dati/git/": it's correct, if I've all my git Areas under this path?
Many thanks
Alberto 


permanent link
Alberto Teodoro (6631631) | answered Feb 17 '17, 5:30 a.m.

Your answer


Register or to post your answer.