It's all about the answers!

Ask a question

RTC custom fields not populated not showing in DW


Jorge Alarcon (41122) | asked Jun 02 '16, 6:07 p.m.
Hi

We have some custom fields on our RTC project area which are not being exported to the DataWarehouse by DCC, when we try to create a report using Report Builder the fields are simply not there.

I have the understanding that there are some fields that by application design are not exported to DW by DCC tool, is there any way to know what fields are intended not to be exported to DW ? or is this an issue that should be fixed?

Regards

3 answers



permanent link
Alexandre Stegani (8664) | answered Jun 02 '16, 6:31 p.m.
Hi Jorge,

You're right, some RTC attribute types are not exported to the Data Warehouse DB by DCC. Large HTML is one of these attributes, please check if this is your case.

Regarding Large HTML specifically, you can use Report Builder and LQE as a data source to use this attribute in your report.

permanent link
Francesco Chiossi (5.7k1719) | answered Jun 03 '16, 5:15 a.m.
Hi Jorge,

in addition to Alexandre's answer you can find an overview of the fields that are available in the data warehouse in the RTC Data Dictionary:

Data dictionary for change and configuration artifacts
http://www.ibm.com/support/knowledgecenter/en/SSYMRC_6.0.2/com.ibm.team.reports.doc/topics/ccm/ccm-roles.html

Best Regards
Francesco Chiossi

permanent link
Jorge Alarcon (41122) | answered Jun 29 '16, 10:06 a.m.
I found the problem was that the application was not auto refreshing the meta model for some reason even though the value metamodel.autorefresh.repeat.inminutes=720 is set up on app.properties so after doing Refresh on data source admin page on Report Builder it updated the meta-model after custom attributes are published to the data source.

The steps to follow were:
1.- Opened Report Builder https://server:port/rs/reports
2.- Go to Data sources
3.- Click on Rational Data Warehouse
4.- Click Refresh

Your answer


Register or to post your answer.