It's all about the answers!

Ask a question

SCM URL could not be found: No such provider: 'jazz'


Sumant Renukarya (4336) | asked Apr 20 '16, 5:08 p.m.
Trying to run Maven Release build using the Maven Release plugin in Jenkins fails with this message:

*****

 Waiting for Jenkins to finish collecting data[ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.0:prepare (default-cli) on project risk-common-lib: The provider given in the SCM URL could not be found: No such provider: 'jazz'. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

*****


Any help? Works fine for other Jenkins jobs for different projects.

Here is the pom.xml entry:

****

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>com.osgt</groupId>
<artifactId>risk-common-lib</artifactId>
<version>16.04.00-SNAPSHOT</version>
<packaging>pom</packaging>
<scm>
<connection>
scm:jazz:https://fitclm.com/ccm:Buildeng_FIT.MCCR_RWSService-risk-common-lib-ITECJenkins
</connection>
<developerConnection>
scm:jazz:https://fitclm.com/ccm:Buildeng_FIT.MCCR_RWSService-risk-common-lib-ITECJenkins
</developerConnection>
</scm>

****

This is the exact entry in rest of the projects:

The repository workspace is:

Buildeng_FIT.MCCR_RWSService-risk-common-lib-ITECJenkins

RTC 5.0.2
Maven build
Build server is a Linux box.

Thank you

Accepted answer


permanent link
Donald Nong (14.4k314) | answered Apr 20 '16, 8:20 p.m.
You didn't mention the Maven SCM Jazz Provider, so the first question for you would be, are you using it at all? You will need it to work with Jazz SCM.
https://maven.apache.org/scm/maven-scm-providers/maven-scm-provider-jazz/index.html
Sumant Renukarya selected this answer as the correct answer

Comments
Sumant Renukarya commented Apr 20 '16, 11:16 p.m.

Hi Donald


How are you? 

Can you please elaborate what you mean by "You didn't mention the Maven SCM Jazz Provider"? 

Like I said, we are able to use this Jenkins plugin to run Maven release builds with RTC just fine for the rest of the projects - all use same settings.xml, pom.xml has the similar entry as above for scm (except the repo workspace changes for each). There is no additional entry for SCM/Jazz in either the pom.xml or the settings.xml file. 

Thanks


One other answer



permanent link
Sumant Renukarya (4336) | answered Apr 20 '16, 11:27 p.m.
 Sorry, spoke too soon. This project had an upstream build project where the maven scm plugin should have been defined but was missing. This was the problem. 

I just need to update the pom.xml for this upstream build project with the maven scm plugin: 

*****

<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-scm-plugin</artifactId>
<version>${maven-scm-version}</version>
<dependencies>
<dependency>
<groupId>org.apache.maven.scm</groupId>
<artifactId>maven-scm-provider-jazz</artifactId>
<version>${maven-scm-version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven.scm</groupId>
<artifactId>maven-scm-api</artifactId>
<version>${maven-scm-version}</version>
</dependency>
</dependencies>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
<version>2.5.2</version>
<dependencies>
<dependency>
<groupId>org.apache.maven.scm</groupId>
<artifactId>maven-scm-provider-jazz</artifactId>
<version>${maven-scm-version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven.scm</groupId>
<artifactId>maven-scm-api</artifactId>
<version>${maven-scm-version}</version>
</dependency>
</dependencies>
</plugin>
</plugins>
</build>

*****

Thanks Donald. 

Your answer


Register or to post your answer.