It's all about the answers!

Ask a question

How could newly added users not show up only in RQM user list ?


long TRUONG (365493132) | asked Oct 22 '13, 1:27 a.m.
 Have added 2 users, while admin an RRC project area (.../jts/applicationAdmin):
  • Can see these 2 users on user list everywhere JTS home (.../jts/admin), RTC project area (.../ccm/admin), and of course RRC project area (.../jts/applicationAdmin)
  • But they are not on the user list when in RQM project area. Cannot find them to add to the RQM membership. They are not on the "list all" to add, nor are they in the active users list.
  • Have started 2 different browsers anew, Chrome, and IE8.
  • Have rebooted, but the issue persisted.
  • Have tried to archive 1 user while in JTS home, then restore, still same issue.
  • Tried to add one of the same user in Dev env, don't have the issue !
  • Can't add them again, they already exist.
  • Tried to create a new user to add to RQM membership directly on the RTC client, but it required a password or would default to username as password, did not try to go further, afraid that with break the credentials sync with AD.
I had thought all 3 RTC, RQM, and RRC are using exactly the same list of users, apparently they are not. How do I add them to RQM membership?

We have CLM 4.0.1 on WAS on a linux server. The sync is via AD somehow (import is greyed out), login controlled by ADgroup externally.


2 answers



permanent link
Erica Tran (1.4k6) | answered Oct 22 '13, 8:51 a.m.
JAZZ DEVELOPER
 Hi Long,
Since you're using LDAP and WAS did you check the user and group mappings in the WAS admin console?  I would compare RQM to the others to make sure they match.

Comments
long TRUONG commented Oct 22 '13, 1:51 p.m.

Thanks Erica. This reminded me to go checking to find the new users now on the RQM list and resolve the issue. I did go into the WAS console though.


permanent link
long TRUONG (365493132) | answered Oct 22 '13, 2:25 p.m.
 Erica: Not enough room on the comment so have to use this answer space.
  • Went into the WAS console, and check on Groups and Users, but there are nothing in there but instructions if using LDAP. However, have added users often, they are instantaneously available to the RQM until today. Hence it couldn't be any systematic cause.
  • Your answer reminded me to go checking if it was just a slow sync, and it was, they were now available for me to add to the RQM membership.
  • But then I got correspondence about an issue we just resolved: The RQM was throwing tantrums on scripts executions, logs showing Oracle DB table space auto-extension failed. The DBA double the table space for us, and voilà everything back to normal. The users appear into the RQM list just about the same time, come to think of it, the link(s) to the user list must have failed to update due to lack of table space, hence it was updated once there is space, as simple as that ! 

Comments
Erica Tran commented Oct 22 '13, 5:11 p.m.
JAZZ DEVELOPER

Hi Long,

So it sounds like everything is all set after the table space had enough room to grow?  If so, please select your own answer as the solution to complete this post.

Thanks.


long TRUONG commented Oct 22 '13, 5:52 p.m.

Wanted to do so when posting the answer and now, but have no mark to pick my own answer as the solution ( forced to be humble :) ) Mark this answer as the accepted answer 


long TRUONG commented Oct 29 '13, 4:59 p.m.

Would have picked this answer of mine as the right one for closure, if only I could have done so. 

Your answer


Register or to post your answer.