It's all about the answers!

Ask a question

Upgrading a mixed version environment


Ben Pitzer (1112) | asked Apr 07 '16, 8:49 a.m.
 Folks,

We have a distributed environment wherein the JTS, JRS, and DCC apps are all on version 6.0.0 iFix 002, while DNG, CCM, and RQM are running 5.0.2 iFix 006.  This was done to allow us to take advantage of the options for ETLs and the report builder improvements in 6.0.0 while keeping the RQM application stable at 5.0.2, at least until the 6.0.1 release was ready and had an iFix or two released.

That said, the time has come for us to upgrade to 6.0.1 across the board, but we now face the dilemma of upgrading a mixed version environment. My instinct is to first upgrade RQM, CCM, and DNG to 6.0 to match the JTS, JRS, and DCC applications, and then upgrade everything together to 6.0.1 iFix 002. Is this necessary, or can I upgrade everything concurrently to 6.0.1? Is there any problem with skipping 6.0.0 altogether for the RQM, CCM, and DNG components, and upgrading everything at once? Has anyone tried this? Unsurprisingly, the interactive upgrade guide in the CLM 6.0.1 documentation doesn't address this scenario (which I'm sure isn't common enough to merit the changes that it would require), so I think I'm hoping that someone else has some experience going off the beaten path in similar fashion.  Thanks in advance.

Regards,
Ben Pitzer

One answer



permanent link
Don Yang (7.0k2186117) | answered Apr 08 '16, 1:09 a.m.
Hi, Ben

Since you are considering upgrade RQM from 502 to v60.1, please have a look at this Flash Alert first for a known defect(from 5.0.x/6.0 to 6.0.1 ifix03(latest) first:
http://www.ibm.com/support/docview.wss?uid=swg21980225

If it applies to your environment, you may consider to upgrade later(until 6.0.1 ifix 04 is available for example) or talk to support to have a discussion.

Your answer


Register or to post your answer.