It's all about the answers!

Ask a question

How do I handle change of user IDs from federated repo to LDAP


Kevin Eifinger (1211410) | asked Dec 16 '14, 11:35 a.m.
My customer started with the tomcat server topology and administered his users there.
Now he is on WAS and in the meantime, due to organisational issues, users got new ids in their LDAP system, so the user ids in jazz are not the user ids found in the LDAP.

1. Changing the user ids in jazz does not work properly for DNG/RQM. We tried that.

2. With WAS and a federated repository a password change by a user is not possible:
https://jazz.net/forum/questions/125637/how-a-simple-user-in-clm-connected-via-federated-users-in-was-can-change-his-password-by-himself

3. Can we somehow link an id in the ldap to an id in the WAS federated repository?

Do you guys have an idea on how to handle this situation?

Accepted answer


permanent link
sam detweiler (12.4k6173200) | answered Dec 16 '14, 6:13 p.m.
when we went thru this as part of a system migration, we exported, then changed the userid in the export, then added the users to the new system (via ldap),
then imported.

some changes fell thru the cracks and the import created userids matching the old system, even tho the user could not logon.

we just changed the workitems to the new userid, then archived the old bad id. (as u cannot delete)

we did not use DNG/RQM at the time. but I assume as they are JTS connected the same operations should be possible (change owner).

for source, there is a mechanism to correct userids..
see https://jazz.net/library/article/535/, section

f. Activate replicated contributors

Kevin Eifinger selected this answer as the correct answer

2 other answers



permanent link
Ralph Schoon (55.6k23642) | answered Dec 17 '14, 3:30 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
In addition to Sam's answer, you can change ID's in RTC to match them to a new LDAP as described here: https://rsjazz.wordpress.com/2012/10/12/changing-the-jazz-user-id-using-the-rtc-plain-java-client-libraries/

permanent link
Timo Reiss (209211) | answered Dec 17 '14, 3:43 a.m.
Hello, thank you for the links, they will definitely help once we solved our issues with RRC.

These are described in the documentation below:

(A) Created WAS and Jazz userID=max (Max Mustermann).
- Max then created a requirement in RRC, linked this to a task in RTC and a TC in RQM.  Max then created a TS in RQM for the TC; Max also ran the test creating a TCER.
- clmadmin added a comment for Max on the requirement, added a child enhancement to Max's task, and directed a comment to max using the @ syntax. clmadmin also created a review for the requirement and added Max as a participant

(B) Then I changed Max's userID to Max.Mustermann in both WAS and JTS and inspected the artifacts.

=> RRC does not realise the changed user ID. It seems as if RRC uses the userID to look up ariffacts:
   - The creator field of the requirement is empty
   - The requirement comment originally directed to Max was no longer directed to anyone; the user field was empty
   - The review did not list Max as a participant but contained a user called "undefined".
   => RRC trips, eliminating all user references. Probably RRC uses the userID itself to look things up.

=> RTC seems to handle the change in the userID.
   - All references to Max were still good. Be it Creator, Owner, Mentioned By, Subscriber, etc.
   - Only the comment containing @ Max was not updated to @ Max.Mustermann (But that is okay since the associated Mentioned By link was correctly updated.

=> RQM seems to handle the change in the userID
   - Owner, Creator etc. were correctly updated and pointing to the existing Max.

Comments
Ralph Schoon commented Dec 17 '14, 3:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Sometimes it can take a while until all the changes are populated. RRC uses the ID's from JTS (until it gets separated from JTS in 5.x).

Your answer


Register or to post your answer.