It's all about the answers!

Ask a question

RTC Email will not turn off without reboot


Donna Thomas (14122041) | asked Aug 15 '15, 11:29 a.m.
Hi there,

We are running Jazz (RRC, RQM, and RTC) 4.0.5. When we import large numbers of work item, we turn off the email so as to not spam all the users who might otherwise get emails from all the records being created. The user attempting to turn it off is a JazzAdmin user (me). This is the location where we turn it off:
https://fullservername:9443/jts/admin#action=com.ibm.team.repository.admin.configureMailSettings

But if the server has not been reboot for a few days (lowest tracked number of days is 4) then when we attempt to set the value of "Enable E-mail Notification" to "false" and click Save, it just hangs with a message "Configuration changes are being saved. This may take a minute...". The first time this happened, we waited over an hour, but it was the middle of the weekend, so their was little to no usage of the tool.

This happens regularly when we try to turn off the email. When we reboot the servers to make it correct itself, sometimes it has saved the change, and sometimes not.

So we looked at the Active Services. The ADMIN user runs a data warehouse collection job at night, and it seems it is still running (more than 14 hours normally when this happens):

com.ibm.team.datawarehouse.service.internal.SnapshotRunnerTask.transactionSucceeded
Then, for each time we try to change the email settings, we get:
com.ibm.team.repository.service.internal.ServerStatusRestService.getComponentsAndStatus

But until we reboot the servers, it does not appear to have changed.

Sound familiar to anyone? If so, help please...
Thank you!

Comments
Abraham Sweiss commented Aug 17 '15, 7:00 p.m.

I would suggest running the wait tool while the issue occurs, and then open a PMR.  This will give support a point to start investigating.
https://wait.ibm.com/
Taking 6 java cores about 30seconds apart should be good to get started with


Alexandre Stegani commented Aug 18 '15, 6:48 p.m.

As a workaround you can disable e-mail settings manually by editing the teamserver.properties file:

<JazzTeamServer>\server\conf\jts\teamserver.properties

Change it to false:

com.ibm.team.repository.notification.mail.enabled=false

2 answers



permanent link
Hakki Bozkurt (1631126) | answered Aug 18 '15, 4:54 a.m.
Hi Donna,

We have seen this problem before... Sometimes, DWH job can not to let save advanced settings. But when it the finish its job we save settings. I think, you look DWH job status before import.



permanent link
Donna Thomas (14122041) | answered Feb 27 '16, 1:28 p.m.
For us, this was fixed in v5.0.2.

Your answer


Register or to post your answer.