It's all about the answers!

Ask a question

RTC as Build Provider in RQM doesn´t work after upgrade to 6.0


Miroslav Zaninovic (36412) | asked Jul 21 '15, 10:01 a.m.
edited Jul 21 '15, 10:04 a.m.
Hi,

after upgrade 5.0.2 to 6.0 Build Providing to RQM does not work.
This message occurs in Project Properties:

The QM server cannot connect to the CCM server. Make sure that the CCM user ID and password are correct. For more information, open the help system

I checked help chapter "Configuring Rational Team Concert as your build provider" in latest help for 6.0.1 again and discovered that section Advanced Properties -> Build Integration Framework -> com.ibm.rqm.buildintegration.service.asynctask.RTCBuildInformationCollector in 6.0

doesn t have option to enter credentials any more.

Is that a bug or I missed some configuration step for 6.0?

Please help.

Comments
paul chu commented Jul 21 '15, 11:17 a.m.
JAZZ DEVELOPER

I don't know much on the build integration set up but until someone have the answer, this is something to look into which I ran into with other authentication issue before.

In RQM, check the OAuth consumer key for the RTC server in the "Friends (Outbound)" setting.  Now in "Consumers (Inbound)" setting of the RTC server, check the "Functional User ID" of the consumer with the matching consumer key to make sure it is the expected user.

2 answers



permanent link
Miroslav Zaninovic (36412) | answered Jul 24 '15, 3:09 a.m.
It is exactly 6.0 iFix001, I have checked whole configuration procedures and seems to be OK, except this detail.
It seems to me as a bug, but I would like to check that on forum first.

permanent link
Paul Slauenwhite (8.4k12) | answered Oct 21 '15, 6:54 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
You must associate a functional user (qm_user) to the consumer entry in the Administrative page of the CCM application. For more details, see Establishing cross-server communication.


Your answer


Register or to post your answer.