It's all about the answers!

Ask a question

JTSMon 5.0.2 showing compatibility error.


Tojan John (1171558) | asked Jun 09 '15, 8:16 a.m.
  Hi,

We have RTC 5.0.2 version on linux server. I downloaded "JTSMon_5.0.2_RTC4.0.2GA" from https://jazz.net/wiki/bin/view/Deployment/JTSMonFAQ#Download_JTSMon . 

While running monitor from my machine after configuring jm.properties, getting below error

Task: ServerSetup(1) ServerVersionCheckException:com.ibm.team.repository.client.ServerVersionCheckException: Your client is version 4.0.2, and the server is version 5.0.2.  These versions are not compatible.

One answer



permanent link
Kevin Ramer (4.5k6172191) | answered Jun 09 '15, 4:45 p.m.
You might ( or ask to have checked ) the Advanced property of the target application server.

Minimum client-compatibility version

The default value would be 4.0 in a 5.X environment.  If it contains 4.0.3 or 5 anything or the "Compatability Mode" is STRICT that message can be presented.

Comments
Tojan John commented Jun 10 '15, 4:28 a.m.

 Kevin,

You are right. In server we have set property to allow client with 5.0.2 version.

How to overcome the JTSMon compatibility issue. I have RTC 4.0.2, 4.0.4 and 5.0.2 in my machine. 


Kevin Ramer commented Jun 10 '15, 9:03 a.m.

It looks like the 4.0.2 Jazz client libraries are embedded in the JTSMon.jar. 

Your answer


Register or to post your answer.