It's all about the answers!

Ask a question

RTC Visual Studio Plugin 5.0.2 CRRTC8500E error when trying to load a Workspace


Marco Simioni (1112) | asked Jun 09 '15, 6:33 a.m.
Dear Sirs,

I'm experiencing a serious issue with RTC Visual Studio plugin 5.0.2, Visual Studio 2012 Update 4, Windows 7 Professional SP1 64 bit.

I can successfully create a new workspace, but when it comes to load the workspace I have the following error:

CRRTC8500E: Server Error: Error executing http://localhost:61997/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/LoadCFA

Exception type:
com.ibm.team.foundation.service.RestTransportException
Exception message:
Error executing http://localhost:61997/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/LoadCFA
Inner exception:
System.Net.WebException: The underlying connection was closed: A connection that was expected to be kept alive was closed by the server. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
   at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
   at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
   --- End of inner exception stack trace ---
   at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
   at System.Net.PooledStream.EndRead(IAsyncResult asyncResult)
   at System.Net.Connection.ReadCallback(IAsyncResult asyncResult)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at com.ibm.team.foundation.service.WebRequestInvocationProxy.ResponseCallback(IAsyncResult ar) in c:\RTC_BUILDS\I5.0.2_20141022-0800\Foundation\ServiceInterfaceProxy\WebRequestInvocationProxy.cs:line 313

I can succesfully load a workspace from the Eclipse RTC Client 5.0.2.

I also noticed that when I try to double-click a modified file under my Pending Changes, the comparison tool just opens and closes immediately without any reason or error - thus I'm not able to use the compare anymore.

BUT The comparison tool on my Visual Studio RTC plugin works if I keep the RTC Eclipse client open (the Load Workspace feature doesn't work anyway).

I already tried the following:
- uninstalled the RTC Plugin, RTC Client, IBM Installation Manager, Visual Studio
- reboot
- reinstalled everything, without any luck

Thank you in advance for your support.

Comments
Marco Simioni commented Jun 09 '15, 9:46 a.m. | edited Jun 10 '15, 5:34 a.m.
Hi all, I have an update.

I think I've found a workaround.

I have replaced the ..\Rational Team Concert Client for Microsoft Visual Studio IDE\3rd Party\scmtools with the ..\TeamConcert\scmtools ones.

Given that the java runtimes configured in scm.ini are different, I also copied ..\TeamConcert\jdk to ..\Rational Team Concert Client for Microsoft Visual Studio IDE\3rd Party\jdk.

And now it works! I can see my pending changes comparisons and I can also load a workspace from the Visual Studio plugin.

It looks that in my environment the scmtools+jre versions shipped with the Visual Studio IDE plugin do not work, while the scmtools+jdk versions provided with the eclipse client work perfectly.

FYI the [1] is the scm.exe --version output of the scmtools shipped with the plugin, while [2] is the scm.exe --version output of the scmtools shipped with the client.

Let me know if you are interested in investigating further on this issue.

----------------------------------------------------------------------------------------------------

[1] 

Build Id: RTC-I20141021-2128

com.ibm.team.filesystem.cli.client, version 3.2.400.v20141016_0123
Provides Subcommands:
  diff, accept, remove/merge-queue, set/flowtarget, delete/workspace,
  remove/component, resolve/current-merge, workspace, create/stream,
  show/conflicts, resume/changeset, changeset, set/current-merge,
  lock/release, baseline, users/set, get/change, component/propertyget,
  list/remotefiles, query, change-target/workspace, list/users,
  workspace/propertyget, conflicts, set/custom-attribute, create/workspace,
  list/merge-queue, list/flowtargets, changeset/disassociate, resolve, unload,
  workspace/remove-flowtargets, debug/fetch, undo/change, component,
  remove/property, baseline/propertyset, logout, create/changeset,
  extract/file, show/status, repair, validate, undo/current-merge,
  snapshot/propertyget, list, property/list, show/history, workspace/unload,
  delete, delete/stream, list/properties, list/changesets, list/states, unset,
  checkin, changeset/locate, show/custom-attributes, list/projectareas,
  show/lastmod, baseline/propertylist, changeset/suspend, preference/get,
  change-target/component, property/set, add/workitem, list/daemons,
  create/component, changeset/complete, undo, changeset/comment, load,
  set/preference, changeset/relocate, set, login, status, move/change,
  workspace/propertylist, show, workspace/change-target, changeset/extract,
  suspend, lock/list, extract, lock/acquire, changeaccess, get/file, locate,
  history, list/changes, changeset/discard, discard,
  workspace/remove-components, add, list/workspaces, list/baselines, lock,
  resume, delete/snapshot, lastmod, workspace/add-components, set/lock,
  workspace/flowtarget, property/remove, delete/state-content,
  workspace/add-flowtargets, annotate, show/properties, list/streams,
  unset/flowtarget, component/propertyset, list/connections,
  list/smartcard-aliases, version, changeset/associate, refresh,
  remove/workitem, share, workspace/component, compare, get/property,
  set/access, workspace/propertyset, change-target/unset-workspace,
  resume/merge-queue, get/preference, create/snapshot,
  list/missing-changesets, add/component, workspace/delete,
  baseline/propertyget, debug/fetch/workspace, remove, unset/custom-attribute,
  get/attributes, list/snapshots, changeset/resume, users, resolve/conflict,
  snapshot/promote, workspace/unset, snapshot/delete, debug/fetch/changeset,
  list/teamareas, remove/flowtarget, list/preferences, create/loadrules,
  snapshot/propertyset, move/path, deliver, set/changeset, property/get,
  snapshot/propertylist, list/components, snapshot, show/attributes,
  add/flowtarget, preference/set, unset/lock, move, property, change-target,
  set/user, debug/fetch/uri, debug, preference, get, set/property,
  debug/fetch/component, debug/fetch/item, component/propertylist,
  create/baseline, get/custom-attribute, set/component, set/merge-queue,
  create, set/attributes, changeset/current, workspace/replace-components,
  list/locks

com.ibm.team.filesystem.cli.tools, version 3.1.800.v20140620_0123
Provides Subcommands:
  tools.verify, tools.pkgtest, tools.echo.stdin, tools.metronome,
  tools.dump/postprocess, tools.dump, tools.configvalue, tools.validate,
  tools.generatehelp, tools.log

com.ibm.team.filesystem.cli.core, version 3.2.400.v20141011_0139
Provides Subcommands:
  daemon/deregister, daemon/start, daemon, daemon/stop, daemon/register

com.ibm.team.rtc.cli.infrastructure, version 3.1.800.v20140619_0246
Provides Subcommands:
  help

----------------------------------------------------------------------------------------------------

[2]

Build Id: RTC-I20141031-0926

com.ibm.team.filesystem.cli.core, version 3.2.400.v20141011_0139
Provides Subcommands:
  daemon, daemon/stop, daemon/register, daemon/start, daemon/deregister

com.ibm.team.filesystem.cli.client, version 3.2.400.v20141016_0123
Provides Subcommands:
  list/streams, set/flowtarget, list/daemons, set/property, create/component,
  annotate, workspace/remove-flowtargets, set/lock, workspace, suspend,
  workspace/unload, unset/flowtarget, compare, undo, baseline,
  create/baseline, set/access, change-target/unset-workspace,
  get/custom-attribute, workspace/flowtarget, change-target/workspace,
  snapshot/delete, users/set, create/stream, list/users, changeset/resume,
  resume, debug/fetch/uri, snapshot/propertylist, set/preference,
  changeset/associate, set/changeset, set/custom-attribute,
  debug/fetch/changeset, show/conflicts, add, move/path,
  workspace/remove-components, set/merge-queue, list/projectareas, list,
  lock/acquire, unload, repair, checkin, property/remove, list/snapshots,
  list/properties, changeset/suspend, resolve/current-merge,
  remove/merge-queue, create, debug/fetch/item, property/get, load,
  changeaccess, get/attributes, workspace/component, list/remotefiles,
  remove/component, set/component, delete/snapshot, changeset/locate,
  changeset/comment, preference/set, property/set, login,
  component/propertyget, debug/fetch/workspace, discard, resolve/conflict,
  list/components, deliver, create/changeset, unset, validate, share,
  resume/changeset, show/attributes, set/current-merge, component/propertyset,
  list/teamareas, add/flowtarget, delete/state-content, remove/flowtarget,
  workspace/add-flowtargets, remove/property, lastmod, get/change,
  undo/change, list/preferences, extract, add/workitem, workspace/unset,
  delete/workspace, set/user, list/smartcard-aliases, show/properties,
  baseline/propertyset, status, debug/fetch/component, change-target,
  show/status, list/locks, diff, changeset, resume/merge-queue, conflicts,
  changeset/extract, lock, version, create/loadrules, changeset/relocate,
  baseline/propertyget, show/lastmod, move/change, unset/custom-attribute,
  delete, preference, component/propertylist, get/preference, list/workspaces,
  logout, changeset/current, delete/stream, users, snapshot/promote,
  workspace/propertyset, workspace/delete, workspace/change-target,
  extract/file, baseline/propertylist, workspace/propertyget,
  workspace/propertylist, show/history, set/attributes, changeset/discard,
  list/changes, lock/release, list/missing-changesets, get,
  changeset/complete, list/states, lock/list, remove, accept,
  list/merge-queue, undo/current-merge, list/changesets,
  workspace/replace-components, changeset/disassociate, refresh,
  list/baselines, workspace/add-components, move, add/component, property,
  get/property, unset/lock, preference/get, create/workspace, create/snapshot,
  get/file, show/custom-attributes, snapshot/propertyset,
  snapshot/propertyget, resolve, property/list, list/connections,
  remove/workitem, component, list/flowtargets, locate, snapshot, set, query,
  show, debug/fetch, history, debug, change-target/component

com.ibm.team.filesystem.cli.tools, version 3.1.800.v20140620_0123
Provides Subcommands:
  tools.log, tools.validate, tools.generatehelp, tools.echo.stdin,
  tools.dump/postprocess, tools.metronome, tools.configvalue, tools.pkgtest,
  tools.dump, tools.verify

com.ibm.team.rtc.cli.infrastructure, version 3.1.800.v20140619_0246
Provides Subcommands:
  help


Marco Simioni commented Jun 10 '15, 5:36 a.m. | edited Jun 10 '15, 5:36 a.m.

I have another update:


If I use the original scmtools from the plugin folder and change the -vm parameter to use the JDK from the RTC client I have the following error:

Cannot load 32-bit SWT libraries on 64-bit JVM

Then I checked the difference between the Jdk/Jre supplied with the two apps and this is the result:

This is the output from the plugin folder:

C:\Program Files\IBM\Rational Team Concert Client for Microsoft Visual Studio IDE\3rd Party\jre\bin>java -version
java version "1.6.0"
Java(TM) SE Runtime Environment (build pwi3260sr16fp1-20140706_01(SR16 FP1))
IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Windows 7 x86-32 jvmwi3260sr16-20140626_204542 (JIT enabled, AOT enabled)
J9VM - 20140626_204542
JIT  - r9_20130920_46510ifx7
GC   - GA24_Java6_SR16_20140626_1848_B204542)
JCL  - 20140704_01

and this is the output from the client folder:

C:\Program Files\IBM\TeamConcert\jdk\jre\bin>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pwa6470sr7fp1-20140712_01(SR7 FP1))
IBM J9 VM (build 2.6, JRE 1.7.0 Windows 7 amd64-64 Compressed References 20140627_204598 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR7_20140627_0924_B204598
JIT  - r11.b06_20140409_61252.04
GC   - R26_Java726_SR7_20140627_0924_B204598_CMPRSS
J9CL - 20140627_204598)
JCL - 20140707_01 based on Oracle 7u65-b16

Please note that I installed the plugin from RTC-VisualStudio-Client-repo-5.0.2.zip and the client from RTC-Client-Eclipse4.2-repo-5.0.2.zip manually configuring the two repositories via Installation Manager 1.8.2.1 (internal version 1.8.2001.20150409_1833).

Why there is such a difference ?

Be the first one to answer this question!


Register or to post your answer.