It's all about the answers!

Ask a question

Report Design perspective is not showing in RTC client after installing BIRT


Shuchita Tripathi (30423180) | asked Mar 26 '14, 2:34 a.m.
edited Mar 26 '14, 4:15 a.m. by Krzysztof Kaźmierczyk (7.2k34390)

I have installed BIRT. But i am unable to see Report Desgin in RTC. BIRT is installed properly because when I am trying to install again, it says already installed.

Perspective

BIRT installed

However, when I saw the .log file inside metadata folder, it shows the following error:

!ENTRY org.eclipse.ui 2 2 2014-03-26 11:39:11.411
!MESSAGE Invalid preference category path: org.eclipse.birt.chart.reportitem.ui.ChartPreferencePage (bundle: org.eclipse.birt.chart.ui.extension, page: org.eclipse.birt.chart.ui.swt.fieldassist.preferences.FieldAssistPreferencePage)

!ENTRY org.eclipse.ui 2 2 2014-03-26 11:39:11.411
!MESSAGE Invalid preference category path: org.eclipse.birt.report.designer.ui.preferences.DateSetPreferencePage (bundle: org.eclipse.birt.report.data.oda.jdbc.ui, page: org.eclipse.birt.report.data.oda.jdbc.ui.preference.DateSetPreferencePage)

!ENTRY org.eclipse.ui 2 2 2014-03-26 11:39:11.427
!MESSAGE Invalid preference category path: org.eclipse.birt.report.designer.ui.preferences.BidiPropertiesPreferencePage (bundle: org.eclipse.birt.report.data.oda.jdbc.ui, page: org.eclipse.birt.report.data.oda.jdbc.ui.util.bidi.preference.JDBCDataSourcePreferencePage)

Kindly help on how to proceed.


Comments
Krzysztof Kaźmierczyk commented Mar 26 '14, 4:14 a.m.

Hi Shuchita,
Two clarification questions.
1. I see that you have installed BIRT 2.5.2. What is the reason you are using so old version? Do you have server in version 3.0.1.x?
2. Please provide the steps you have exactly used to install BIRT and RTC (How did you install it, what was the base product etc.)


Shuchita Tripathi commented Mar 26 '14, 5:00 a.m.

Hi Krzysztof,

Following are the steps which I used for BIRT installation in RTC.

1. Open the RTC client and click on Help ->  Install New Software…

2. Click on Available Software site.

3. Check if http://download.eclipse.org/releases/galileo is added or not. If not, then add it in the Add section, otherwise just click the checkbox for this site and click on OK.

4. Select the site in the Work With drop down and click on Business Intelligence Reporting and Charting. Then click on Next.

5. Click on Next, till Finish. BIRT will be installed. Restart of RTC client will be asked. Restart it.

I have RTC 4.0.4 version.

I was not asked to choose BIRT version. It was automatically taken.


Shuchita Tripathi commented Mar 27 '14, 7:13 a.m.

Hi Krzysztof,

I now installed BIRT from http://download.eclipse.org/releases/helios to get recent version, but still I am not able to see report design perspective.

I also checked the plugins folder and there are birt plugins present in it.

Please advise how to proceed.

Accepted answer


permanent link
Stefan Riedmüller (47126) | answered Jul 10 '14, 4:50 a.m.
Hello,

I had the same problem (can´t see the Report Perspective). I try a lot of different things. I had resolved my problem by executing the RTC Client as an Administrator (right Click & Run as Administrator).
Shuchita Tripathi selected this answer as the correct answer

Comments
Shuchita Tripathi commented Jul 10 '14, 9:52 a.m.

Will try it out.

Did u install Juno? 


2 other answers



permanent link
Shuchita Tripathi (30423180) | answered Mar 27 '14, 8:29 a.m.
I installed http://download.eclipse.org/releases/juno and it worked. I am now able to see Report Design perspective.

Steps to install:

1. Open the RTC client (mine is v4.0.4) and click on Help ->  Install New Software… 

2. Click on Available Software site. 

3. Check if http://download.eclipse.org/releases/juno is added or not. If not, then add it in the Add section, otherwise just click the checkbox for this site and click on OK. 

4. Select the site in the Work With drop down and click on the following:
WTP: Web, XML, and Java EE Development > Eclipse Web Developer Tools  
EMF: Modeling > EMF - Eclipse Modeling Framework SDK  
DTP: Database Development > Data Tools Platform > Install all of the Data Tools Packages. 
BIRT: Business Intelligence, Reporting and Charting
Then click on Next. 

5. Click on Next, till Finish. BIRT will be installed. Restart of RTC client will be asked. Restart it. 

permanent link
Yannick Schildknecht (1625) | answered Apr 03 '14, 6:14 a.m.

Hello,

just one thing : I'm not sure the Juno version of BIRT is compatible with the RTC server, you might not be able to upload your reports, or run them. I think RTC need BIRT 2.6.2, at least for RTC 4.0.x.
 

The steps described in "Installing BIRT tools" in the RTC 4.0.6 online help seem to work (though there is some confusion about the versions of dependencies to use).

Your answer


Register or to post your answer.