It's all about the answers!

Ask a question

Running out of heap space when loading workspaces

Dave Crighton (1123) | asked Mar 04 '16, 9:51 a.m.
After a reinstall of the 5.02 eclipse client I am now unable to load workspaces of any size beyond a few dozen files in the eclipse client, getting out of memory errors reported as shown below.

An internal error occurred during: "Loading repository items".
java.lang.OutOfMemoryError: Java heap space

I have already tried setting the max heap in eclipse.ini, scm.ini and but this has not helped (-Xmx4096m). Strangely dumps produced on failure are only 1.1Gb whihc would seem to indicate that the settings are not taking effect.

Running on linux if it makes any difference. HAve also tried updating to interim fix 11, still no joy.

One answer

permanent link
Dave Crighton (1123) | answered Mar 04 '16, 11:18 a.m.
Ive figured this out, the problem is that I was using "lock to launcher" in unity so I could easily launch eclipse, when you do this ubuntu creates a .desktop file in  ~/.local/share/applications/rational_team_concert.desktop which include -Xmx512m overriding the eclipse.ini.

The clue was that the javacores listed Xmx as being set to 512mb and this got me looking at starting the program in diffeent ways using the heap indicator built into eclipse to check the results.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.