It's all about the answers!

Ask a question

CLM and memory allocation

Sterling Ferguson-II (1.6k9282269) | asked Feb 02 '13, 8:33 p.m.
WAS 7.0.23
Linux Redhat


When I go in to jts/admin, I see an allocation of memory at 4GB and a max of 4GB. The server has 16GB and does nothing else. How/where can I get this increased to 8GB+?


Accepted answer

permanent link
Krzysztof Kaźmierczyk (7.5k477103) | answered Aug 29 '13, 2:48 a.m.
Hi Sterling,
You need to remove -Xmx4g -Xms4g from the arguments. These parameters are set in was by specifying Initial and maximum heap size. After removing these parameters and restarting WAS it should be working correctly.

Let us know if it helps for you.

Best regards,
Krzysztof Kazmierczyk
Sterling Ferguson-II selected this answer as the correct answer

5 other answers

permanent link
Benjamin Silverman (4.1k610) | answered Feb 02 '13, 10:56 p.m.
Hi Sterling,

If you want to increase the maximum JVM heap size on a CLM application running on WebSphere, you can do it from the WebSphere admin console (ie -  The recommendation is to set the maximum heap no higher than 1/2 the available physical memory assuming you're only running one WAS profile.

Once logged in to the WAS admin console, go to Servers -> Server Types -> WebSphere Application Servers -> <server_name> -> Java and Process Management -> Process Definition -> Java Virtual Machine -> You'll see the initial and maximum heap size there.  The recommendation is to set them to the same value.  Here is the documentation on JVM settings from the WebSphere 7.0 InfoCenter.  Hope it helps,

Guido Schneider commented Feb 04 '13, 4:48 a.m. | edited Feb 04 '13, 4:52 a.m.

I would also have a look at:

Track recommended JVM options for running CLM servers 
(Jazz Collaborative ALM, Task: 198140)

We are running 4 parallel profiles with this recommended settings with very good results.

permanent link
Benjamin Silverman (4.1k610) | answered Feb 05 '13, 12:28 p.m.
Hi Sterling,

The issue is that your -Xmx and -Xms are set to 4G in your JVM arguments, so they're overriding the settings you've adjusted.  You can either update them in the JVM arguments (change -Xmx4G -Xms4G to -Xmx8G and -Xms8G), or remove them and keep the properties you've set in the Min/Max settings on the same page.  Either one will fix the issue.

permanent link
Sterling Ferguson-II (1.6k9282269) | answered Feb 05 '13, 11:11 a.m.
@Benjamin: I must be doing something wrong. I went into WAS and changed it to 8192...and it still shows the same after a WAS restart:

What does the Free indicate? Do I have something set wrong?


VM Memory Usage
Maximum Memory Allocation 4096 MB
Current Memory Allocation 4096 MB
Free Memory 82 %

permanent link
Benjamin Silverman (4.1k610) | answered Feb 05 '13, 11:16 a.m.
edited Feb 05 '13, 11:28 a.m.
Hi Sterling,

Can you confirm the configuration was saved by checking the properties again after the restart?  If not, you'll need to make the changes again, save the configuration when prompted, then restart WAS again.

The "Free Memory" indicates the amount of memory not in use (so a high number there is good).  You can also check more specific JVM usage statistics by going to https://server:port/rm/rmadin -> Logging -> View JVM Properties (at the bottom of the page).  I'm not sure the "Current Memory Allocation" in your screenshot is showing the actual allocation, but rather the minimum heap.  The RM page I mentioned above shows a better breakdown of memory usage.

permanent link
Sterling Ferguson-II (1.6k9282269) | answered Feb 05 '13, 12:07 p.m.
Hello Benjamin:



Here are my arguments:
-Xmx4g -Xms4g -Xmn512m -Xgcpolicy:gencon -Xcompressedrefs -Xgc:preferredHeapBase=0x100000000

JVM Memory

Name Heap Initial size Max size Currently Used Committed (Reserved)
Non Heap false 0 0 374.7 MB 569.3 MB
class storage false 0 0 322.6 MB 435.7 MB
JIT code cache false 0 0 24 MB 24 MB
JIT data cache false 0 0 10.3 MB 16 MB
miscellaneous non-heap storage false 0 0 17.7 MB 93.7 MB
Java heap true 4 GB 4 GB 543.2 MB 4 GB

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.