It's all about the answers!

Ask a question

User id cannot connect to the repository because it is not assigned to a repository group that has permission to access the repository


Shuchita Tripathi (31435290) | asked May 11 '15, 3:29 a.m.
Hi,
We are using LDAP to connect to RTC.
There is one user who is not able to login. Whenever he logs in, he get the error.
"user id cannot connect to the repository because it is not assigned to a repository group that has permission to access the repository"

I have added him in Jazz Users group in LDAP and also created a user ID for him in CCM.

All other users are able to login.

Can someone please suggest what can be the issue?

RTC v5.0
Websphere v8.5
LDAP

Accepted answer


permanent link
Ralph Schoon (61.5k33643) | answered May 11 '15, 3:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
If this works for all users, except this one, check the user record in LDAP and check the logs. This should not be a configuration issue at first glance, as the other users can login. Check the user record in CLM and look at the repository groups mapped to the user - likely none. Look for typos in LDAP. You could also approach support to get more information e.g. for logging.

Another approach would be to follow the hints on the LDAP Setup page. It describes how to test your settings and you could use it with the user that does not work to get a better idea, why.
Shuchita Tripathi selected this answer as the correct answer

Comments
Ralph Schoon commented May 11 '15, 5:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Did you solve the problem? What caused this?


Shuchita Tripathi commented May 13 '15, 9:53 a.m.

I removed the user from JazzUser group and added again. Ran the LDAP synch manually. Then it started working.

Your answer


Register or to post your answer.