It's all about the answers!

Ask a question

missing patch org.eclipse.emf.ecore.editor.R422patch_1.0.0


Nada Loutfallah (116) | asked Mar 03 '15, 6:22 a.m.
Hi,

I try to install RTC - client for eclipse 4.2.xIDE4.0.7  into Eclipse Juno 4.2 the following error appear:
Error: Feature patch "org.eclipse.emf.ecore.editor.R422patch_1.0.0" is missing

Where I can locate this patch

Thanks


3 answers



permanent link
Bryan Florkiewicz (111) | answered Mar 18 '15, 4:05 p.m.
edited Mar 18 '15, 4:07 p.m.
Hi Nada.

I haven't been able to locate this patch myself and have experienced the same issue.

I did discover that this error does not occur if you try to extend RTC off of a Juno 4.2.2 SR2 - Java Developers instance (Eclipse IDE Juno SR2 Downloads, 3rd link down). There must be a patch/feature/plugin in the Java Developer version that is not present in the Classic or Java EE versions.

Be sure to patch the Java Developer version with the other avaliable patches here before trying again.

Best of luck.


permanent link
Eric Benzacar (41512) | answered Apr 24 '15, 4:31 p.m.
 Were you ever able to succeed?  I am becoming increasingly frustrated trying to install/inject RAD 9.1 into an Eclipse 4.2.2 Juno install.

I've pointed my IBM Install Manager to my Eclipse WTP installation, but it keeps whining about packages missing.  I tried following the instructions here, but cannot create update sites from the plugins.  I finally just copied all the zips into the eclipse folder, but I still end up with Feature patches that are missing.  I had to manually download the WTP 3.4.2 patches  but am still a few packages short and cannot seem to get this working.

At the moment, I'm missing the following patches, and have no idea where to find them:
com.ibm.jsdt.42.feature.patch_1.0.0.v20130909_1742
com.ibm.jsdt.jst.web_ui.42.feature.patch_1.0.0.v20130909_1742
com.ibm.jsdt.wst.web_ui.42.feature.patch_1.0.0.v20130909_1742
org.eclipse.emf.ecore.editor.R422patch_1.0.0

Were you able to find any of these patches?

Comments
Eric Benzacar commented Apr 26 '15, 10:21 p.m. | edited Apr 26 '15, 10:21 p.m.

  @DonaldNong - Thanks but I'm trying to push in a RAD 9.1 with an RTC 4.0.2 client.  Maybe I can find the missing pkgs on the RTC 5 P2 repo, although I'm not quite sure how I would go about finding those.  Not even sure where the RTC 5 P2 repo is.


Donald Nong commented Apr 26 '15, 10:29 p.m.

I think p2 is still available with the RAD client. Here are the direct links to the p2 packages.

For any RTC version, just go to the "All Downloads" tab and search "p2".


Eric Benzacar commented Apr 27 '15, 1:57 p.m.

Thanks for the links.  I tried installing the RTC client with all its dependencies, but then when I went to install RAD via the installation manager, I still get the same 4 pkgs that are missing.  


I've tried everything I can think of, including scavenging the missing pkgs from an existing RAD installation and dropping them in a Juno install (both the features and the dropin folders) with no luck, as well as even trying to create a local P2 repo with those 4 features, but Eclipse refuses to install them.

To say this is frustrating is an understatement!


Donald Nong commented Apr 28 '15, 1:34 a.m.

I checked the installation packages for RTC and RAD, the missing files are actually there. So I'm not sure why IM does not pick them up. You'd better contact Support to figure it out.


permanent link
Donald Nong (14.4k213) | answered Apr 26 '15, 9:03 p.m.
According to this post, using P2 installer instead of IBM Installation Manager resolves the issue.
https://jazz.net/forum/questions/168459/install-rtc-client-501-on-eclipse-juno-422-fail

Your answer


Register or to post your answer.