It's all about the answers!

Ask a question

How to load a workspace if it's already owned by a daemon?


P. A. (1817) | asked Feb 12 '15, 12:05 p.m.
Hi,

I'm getting the following error message when trying to load a worksplace using lscm load command

"Sandbox /root/workspace/MyWorkspace is already owned by daemon running on port 34921"

How can I stop that process and load the workspace? I've tried the following command, but I end up with another error message saying "unknown subcommand demon"

lscm demon stop -p 34921


2 answers



permanent link
Lily Wang (4.9k714) | answered Feb 12 '15, 7:28 p.m.
Hi Parvez,
You can use "scm daemon stop -p 34921".

Comments
P. A. commented Feb 13 '15, 8:56 a.m.

Thank you Lily for your reply. I've already tried that scm command but unfortunately that didn't work either. I can't seem to execute scm commands. Get error saying "scm: not found"

I had also tried the following commands, but all of them returns the error about unknown subcommand daemon or demon

 lscm demon stop -p 34921
 lscm demon stop -a
 lscm daemon stop - p 34921
 lscm daemon stop -a


Evan Hughes commented Feb 13 '15, 10:54 a.m.
JAZZ DEVELOPER

'lscm' doesn't know how to run daemon start/stop subcommands. You have to call 'scm' to perform those actions. 


The "scm: not found" error suggests that 'scm' isn't in your path. 


permanent link
P. A. (1817) | answered Mar 03 '15, 3:21 p.m.
Thanks Evan for your reply. After further troubleshooting, I found out the location where scm.sh is located. I used this utility to stop those daemon that were running.

scm.sh daemon stop -p <port number>

Your answer


Register or to post your answer.