It's all about the answers!

Ask a question

RTC pulldown does not populate


Dan Coll (1613) | asked Dec 30 '14, 2:37 p.m.
edited Dec 30 '14, 2:38 p.m.

I'm a new RTC user trying to configure a basic, simple, customized work item.  I created an enumeration called DD with 3 values.  I then tried to use it in a work item type with an attribute called DD, with a type of DD (Enumeration).  It is intended to be a single value a user chooses from a pulldown.  I then added the DD field to the Editor Presentation, using an Attribute-based Presentation with a Kind of Enumeration.  I've seen this work on other work items.  When I try to create a new work item of this type, I click the arrow next to the DD field to display and choose a value, but the pulldown will not populate, it just says "Retrieving ...".  Help!

Running RTC 5.0.1.


Comments

Dan Coll commented Dec 31 '14, 9:59 a.m.

Thanks for your response Donald.  Some of the symptoms are definitely the same, but I don't have access to any of tools you mention, such as Firebug.  I'm trying to configure this work item using only the web UI.  I don't have Eclipse either. 

My form (all tabs included) has 20-25 attributes.  I had most on one tab, so I split that into 2 tabs, rebuilding the 2nd tab from scratch.  That did not help.  I will contact Support for further assistance.  Thanks.

3 answers



permanent link
Eric Jodet (6.3k5109120) | answered Jan 02 '15, 4:53 a.m.
JAZZ DEVELOPER
 Hello Dan,
Donald was referring to some WebUI debugging tools.
Firebug is a Firefox plugin (you may google for firebug).

Most of the Dev Team use Chromium which is very powerful.

Using such tool, you might be able to determine why your combo is not populated.

More details on our Wiki page.

Eric

permanent link
Robert Stewart (1813) | answered Jan 29 '15, 12:50 p.m.
Hi Dan,

I am having exactly the same issue, with RTC 5.0.1.

Did you resolve this?  How?

I installed Firebug, but couldn't really figure out what it was telling me.  Any tips on what to look for in Firebug would be appreciated.

Thanks

Rob Dropdown stuck on "Receiving"

Comments
Donald Nong commented Jan 29 '15, 10:09 p.m.

Rob,
For a short walk-through, you can check this article.
http://www.ibm.com/developerworks/library/wa-aj-firebug/
You will need some knowledge about HTTP GET, POST and PUT operations and what should be the response.
For this particular issue, you need to check the GET request
/ccm/service/com.ibm.team.workitem.common.internal.rest.IWorkItemRestService/allValues?...
(it should return a JSON content with the enumeration values)


permanent link
Robert Stewart (1813) | answered Feb 05 '15, 11:10 a.m.
Problem solved!

Hi all,

I guess I wasn't using a specific enough ID and that was causing confusion. 

I went with Sandbox.workitem.story.requestor.ID

And when I created the enumeration type, I restricted it to this list, and not taking items from the database.

It all works now.

Thanks guys.

Rob

Your answer


Register or to post your answer.