It's all about the answers!

Ask a question

[closed] Dropdown lists in RTC WI no longer expand into enumerations and each of most attributes got a red circled X mark ([object Object] when hovered over)


long TRUONG (3654121147) | asked Sep 16 '14, 12:48 a.m.
closed Oct 10 '14, 2:49 a.m. by Ralph Schoon (63.2k33646)
 Any idea where to start looking, after our upgrade (RTC/RRC) to 4.0.6 from 4.0.3, all (of WI types using customized WF Scope Item) WI dropdown lists perpetuate with "retrieving ..." without being populated with enumerations on webUI, although OK on Eclipse clients. 

Also most attributes turned mandatory on webUI and prevented moving to next state, while on Eclipse clients the WI can be put into next state without a single attribute requiring an assigned value.

Have checked into one attribute with dropdown list to enumerations: The associated enumeration got a default literal, tried:
  • Adding an enumeration entry to Unassigned Literal did not help
  • Also ticking the attribute read only did not help
  • Attribute does not have a default value, however it's greyed out hence no writing into the field.
  • All this in consideration of an RRC bug which prevented import of artifacts with enumerations without an initial value (in combination with the existence of a description).
Have not look into the issue with mandatory fields yet.


dropdown &mandatory issue
                                                                                                                                                                                                                

Comments
Ralph Schoon commented Sep 16 '14, 2:31 a.m. | edited Sep 16 '14, 2:32 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would consider getting in contact with support. If something like that happens I would assume an issue with the upgrade. Also 4.0.7 has a lot of bug fixes.


Donald Nong commented Sep 16 '14, 3:04 a.m.

It reminds me of a case where the RTC Web client would stay at the "saving work item" message, and it turned out to be a client side JavaScript error due to an obsolete attribute (the operation stops at the client side, not the server side as it appears). There will be some debugging required to find that cause. So as Ralph said, open a ticket with Support.


long TRUONG commented Sep 16 '14, 11:06 a.m.

Thx Ralph & Don,


Had updated the preemptive [PMR 41851 49R 000] for the upgrade with these issues.

We had planned to upgrade to 4.0.7, as also advised by IBM. However no compatible version of Tasktop (Sync) is available so we had to switch to 4.0.6 at the last minute.

One factor which influenced our decision to go to 4.0.7 was the SQLserver 2012 we had used all along with our 4.0.3 and it is not compatible with 4.0.x till 4.0.7. This made us very uneasy going to 4.0.6 but we had no choice.

I had tried to sync all WIs in case the missing sync is causing these issues, but running into heap space on clients so far. 


long TRUONG commented Sep 17 '14, 12:41 p.m.

IBM had requested a new PMR separate from the upgrade PMR:  [PMR 55525,49R,000] 


long TRUONG commented Sep 23 '14, 4:37 p.m.
 I stand to be corrected on second half of the original description: 
  • "Also most attributes turned mandatory on webUI and prevented moving to next state" was not true, it was the wrong observation. 
  • It should have read "The red circled X marks are not  indicators of mandatory fields, the tickets can be moved to next state without any of them has to disappear. And you can remove the marks by  clicking, no need to set, the field, at least for the non-enumeration fields."
The PMR has been escalated with logs collected by HTTPwatch and by Firebug as well as Chrome "Inspect Elements"

long TRUONG commented Oct 02 '14, 10:51 p.m.

New development: posted on Jazz Forum Question 164756, now focusing on "NetworkError: 400 Bad Request - https// ....." 


long TRUONG commented Oct 09 '14, 5:20 p.m.

 This question has been rephrased to one directly related to a 400 Bad Request error, which received the right answer (for the workaround of the immediate cause) from Donald Nong: Forum Question 164756


Ralph Schoon commented Oct 10 '14, 2:51 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I closed this thread since the question was rephrased in  Jazz Forum Question 164756 I think this question will never be closed.If you disagree, let me know and I can reopen it.

showing 5 of 8 show 3 more comments

The question has been closed for the following reason: "Other" by rschoon Oct 10 '14, 2:49 a.m.