It's all about the answers!

Ask a question

RRDI 5.0 Troubleshooting "No Data Available" Charts, blank Crosstabs


Larry McCarthy (2102024) | asked Jul 16 '14, 7:59 p.m.
edited Jul 16 '14, 8:01 p.m.
Something is wrong with this RRDI installation. I need some suggestions on how to troubleshoot this (unless you know the answer, which I'll be happy to hear! :) )

Platform: CLM 5.0 (just CCM, JTS), DB2 10.5, WAS 8.5.5.2, upgraded from 4.0.1, 9.7, Tomcat (resp.).
Installed RRDI, including DCC (with HotFix) and JRS from the 5.0 distribution. Single Windows 2K8 R2 server.
All App jars in the same App Server, jrs and dcc under the CLM /server/conf. (Yes, I know, but the customer insists; gave the JVM 8GB, it hums along at 74% free). Auth is via LDAP.

In Report Studio, list-type reports work fine. The data is visible in ODS and it's clear that DCC is sending ODS updates hourly, as scheduled. All of this testing uses the Request (Work Item) table of ODS. The goal is to produce Work Item reports and charts using a number of the customer's custom WI attributes (many / most are enums). I've built queries in Report Studio that find and arrange these for reporting. But summarizing reports won't summarize, and charts all produce "No Data Available". So, I tried some very simple reports and charts (without 2-3 levels of Joins to resolve Enums and their literals)

A simple "list" report of, for example, Owner Name and Reference ID (WI #) works fine. If you group by Owner Name and set Reference ID to aggregate by Count Distinct (# of WI's per Owner), that works, too. But, trying to make that report into a Pie Chart (WI's per Owner) always produces "No Data Available".

A simple Crosstab of, say, Owner Name vs. Project Name (row, column headers), with the "measure" being count-distinct of Reference ID (WI #) correctly populates the row and column headers, but all the cells are blank. More complicated queries produce the same kind of results - good "list" reports, "No Data Available" charts, and either blank Crosstab cells, or, sometimes, Crosstab cells all filled with grand totals.

How to begin (and, better yet, finish!) troubleshooting this problem?

Thanks,
Larry.

One answer



permanent link
Rafik Jaouani (5.0k16) | answered Jul 17 '14, 8:46 a.m.
JAZZ DEVELOPER
Larry, can you please export the report to a file and may be get it to us so we can test?

Comments
Larry McCarthy commented Jul 18 '14, 12:32 p.m.

Emailed an example to you, Rafik. (Didn't want to subject the other Forum readers to all that XML :) ).

Your answer


Register or to post your answer.