It's all about the answers!

Ask a question

RTC Setup in local gets CRJAZ1841W error. It says we can ignore but unbable to find an option do to so


Binnu Thomas (611) | asked Jun 04 '14, 10:23 a.m.

I was in the process of setting up RTC in my local machine and was using localhost as domain name. During the setup, on the first page "Configure Public URI", the system automatically detects https://localhost:9443/jts as public URI. Upon selecting Step 2: Confirm Public URI, and trying to proceed, it give me error.

"A connection could not be established with the following URI: "https://localhost:9443/jts". Ensure that Jazz Team Server or the application is configured correctly and running.ID CRJAZ1860E "

On clicking "show details", it says we can ignore the message,

"The host "localhost" is not a fully-qualified domain name. You may ignore this warning if you are running the server on your local workstation and will not need to access this repository from other workstations in the future. Otherwise you must use an appropriate fully-qualified domain name for the Public URI hostname, as in "example.mydomain.com".ID CRJAZ1841W"

But I don't see any option I don't see an option to ignore and move on to the next step. How can ignore the message and continue with the set up? The “NEXT” and “FINISH” buttons are grayed out and I cannot proceed.

Things I did.

1)    I tried to add “127.0.0.1           localhost” in host file

2)    I tired to create a new domain name that will look back by adding “127.0.0.1   myserver.local.com” in host file and configured https://myserver.local.com:9443/jts as URI

3)    Clicked again and again on the “test connection” button. Well it don’t workno matter how many times I clicked.

Any suggestions?


Comments
Piotr Aniola commented Jun 04 '14, 11:39 a.m.

Did step 2 work for you?

2)    I tired to create a new domain name that will look back by adding “127.0.0.1   myserver.local.com”
in host file and configured https://myserver.local.com:9443/jts as URI


Binnu Thomas commented Jun 04 '14, 12:59 p.m.

No. All my steps has failed.

3 answers



permanent link
Karl Weinert (2.0k42636) | answered Jun 04 '14, 1:30 p.m.
JAZZ DEVELOPER
Can you try using your real IP address in the hosts file.
Kind of a pain if the ip address changes a lot but it would at least be a good test.

Are you on Windows or Linux?



Comments
Binnu Thomas commented Jun 04 '14, 2:49 p.m.

Yes I tried IP and it didn't work as well.

I am installing in Win 7 laptop as a non-admin user.


permanent link
Binnu Thomas (611) | answered Jun 04 '14, 2:49 p.m.

I just noticed the below error in my tomcat logs:

org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [equinoxbridgeservlet] in context with path [/jts] threw exception [Failed to determine authentication method.  The URL from the request is: https://127.0.0.1:9443/jts] with root cause
Throwable occurred: java.net.SocketException: Permission denied: connect
 at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:412)
 at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:271)
 at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:258)
 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:376)
 at java.net.Socket.connect(Socket.java:546)
 at com.ibm.jsse2.SSLSocketImpl.connect(SSLSocketImpl.java:541)
 at org.apache.http.conn.ssl.SSLSocketFactory.connectSocket(SSLSocketFactory.java:375)
 at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:148)
 at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:149)
 at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:121)
 at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:573)
 at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:425)
 at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:820)
 at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:754)
 at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:732)
 at com.ibm.team.repository.service.internal.identity.UserIdentityHelper.determineAuthMethod(UserIdentityHelper.java:116)
 at com.ibm.team.repository.service.internal.identity.UserIdentityHelper.determineAuthMethod(UserIdentityHelper.java:94)
 at com.ibm.team.repository.service.internal.identity.UserIdentityHelper.getAuthMethod(UserIdentityHelper.java:264)
 at com.ibm.team.repository.servlet.AbstractTeamServerServlet.service(AbstractTeamServerServlet.java:1867)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
 at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
 at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
 at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:126)
 at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:76)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
 at org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:120)
 at com.ibm.team.repository.server.servletbridge.JazzServlet.service(JazzServlet.java:74)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
 at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
 at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
 at com.ibm.team.repository.server.servletbridge.BridgeFilter.processDelegate(BridgeFilter.java:165)
 at com.ibm.team.repository.server.servletbridge.BridgeFilter.doFilter(BridgeFilter.java:198)
 at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
 at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
 at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
 at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
 at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:581)
 at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)
 at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
 at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:336)
 at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
 at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
 at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1002)
 at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:585)
 at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:312)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:906)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:929)
 at java.lang.Thread.run(Thread.java:761)


permanent link
Ken Tessier (84117) | answered Jun 06 '14, 4:59 p.m.
 Hi Binnu --

Did you select the checkbox next to "I understand that once the Public URI is set, it cannot be modified except with additional administrative commands and in a limited set of scenarios, which can result in broken links from other applications that do not support changing URLs."?

In my experience, the Next button remains inactive until I select that checkbox.  Then it becomes active.

Ken

Your answer


Register or to post your answer.