It's all about the answers!

Ask a question

Strange behavior with RQM and RPE -- please help


Joe Gariano (882937) | asked Apr 22 '14, 4:36 p.m.
I've narrowed down the following issue that is causing us problems for some test documentation we are generating with RPE and RQM.  I have a simple recipe for reproducing the error, which is as follows...

I have an RPE template (.dta file) that creates a simple table, where each row of the table is a test case.  The RPE template takes a data source that it queries to build the table.  In this case, the URL I'm using for the data source is simple, namely, the list of all test cases in a project:
https://myserver:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_Sandbox/testcase?abbreviate=false&calmlinks=true

If I statically configure the data source (i.e. supply the above URL in the .dsx RPE file), then all of the test cases get printed out correctly.  However, if I put at the top of my .dta file (above the table) a dynamic data source configuration element (the thing that appears in orange in RPE), and then I paste in the the above URL into the URI field of that dynamic data source configuration, the problem happens.  The problem is that only 50 test cases are printed to the table.  If I have 50 or less test cases in the database, it works fine.  But if I have more than 50, I only see 50 in the table.

It appears that configuring a data source dynamically limits the amount of data that RPE can process (in this, to 50 test cases).  Does this issue ring a bell to anyone?  If so, is there a way to fix it?

Thanks,
Joe Gariano

Comments
Subramanya Prasad Pilar commented Apr 23 '14, 8:00 a.m.

Which version of RPE are you using?


Joe Gariano commented Apr 23 '14, 1:08 p.m.

We're using RPE 1.2


Subramanya Prasad Pilar commented Apr 23 '14, 1:15 p.m.

I am using RPE 1.2.1.1 and I see all testcases even when the datasource URL is provided in URI field of data source configuration element. Can you provide the .dta file?


Joe Gariano commented Apr 23 '14, 1:17 p.m.

How do I transmit it to you?


Subramanya Prasad Pilar commented Apr 24 '14, 3:47 a.m.

You can mail it.


Joe Gariano commented Apr 24 '14, 9:39 a.m.

Pardon my ignorance... but to which address?


Subramanya Prasad Pilar commented Apr 24 '14, 12:46 p.m.

subprasad@in.ibm.com

showing 5 of 7 show 2 more comments

Accepted answer


permanent link
Subramanya Prasad Pilar (3.3k13) | answered Apr 23 '14, 12:47 a.m.
edited Apr 23 '14, 12:58 a.m.
This is because the default size for each page of RQM feed is 50 entries and if the entries are more than 50, there will be paging links. When the URL is supplied in .dsx, RPE automatically takes care of paging links.
You can try either of these:
1. Configure number of entries in each page (change Max Feed Entries/Page in JTS - Server Administration)
2. append &size=n to the URL (where n is >= total testcases)
Joe Gariano selected this answer as the correct answer

Comments
Joe Gariano commented Apr 23 '14, 1:10 p.m.

Thank you.  Two follow up questions:
1) I noticed that the max value for this configuration on the server is 1000.  Is there a reason why its not infinite by default?  What do you sacrifice (e.g. performance) by increasing that value?
2) For the size=n setting, can n be as large as we want?  Or is it too capped at 1000 or some other number?


Subramanya Prasad Pilar commented Apr 23 '14, 1:18 p.m.

Did you workaround work for you? For the follow up questions, someone from RQM team can provide accurate answer.


Joe Gariano commented Apr 23 '14, 3:06 p.m.

If by work around you mean increasing the server setting, yes, we bumped it up to 1000 and now the RPE script works.  But we still have open questions, namely, the two I posted above.

Thanks,
Joe

2 other answers



permanent link
Subramanya Prasad Pilar (3.3k13) | answered Apr 25 '14, 2:41 a.m.
I do not see the issue with RPE 1.2.1.1. Can you please try this after upgrading RPE to 1.2.1.1?

permanent link
Joe Gariano (882937) | answered Apr 28 '14, 9:55 a.m.
Yes, I will try it once I get RPE 1.2.1.1 installed.

Thank you for your help.

Regards,
Joe

Your answer


Register or to post your answer.