It's all about the answers!

Ask a question

DM and RM bi-directional links


Dmitry Gorshenin (969) | asked Apr 11 '14, 9:20 a.m.
Hi,

I have JTS 4.0.6 and try to add links to DM artifacts. Working with a DM artifact (e.q. UML diagram), when I assign an  'Elaborates' link and choose the appropriate CCM work item, this work item gets an 'Elaborated by Architecture Element' link to the DM artifact automatically. But when I assign a 'Derives From' link and choose the appropriate RM requirement, no links to DM artifact appears on this requirement. I have read many related articles and forum topics, but still haven't found a reason of my issue.

Could you please tell me your ideas (if any)?

Thanks a lot in advance

2 answers



permanent link
Gabriel Ruelas (1.1k13) | answered Apr 11 '14, 9:30 a.m.
Hi,   Are you able to create a Derives link from an RM artifact to a DM artifact ( in the RM application ) ?

Comments
Dmitry Gorshenin commented Apr 11 '14, 9:49 a.m.

Hi Gabriel,
'Derives' link type is available on RM requirements, but when I try to create such links, I have no opportunity to select DM project area and artifact (


Gabriel Ruelas commented Apr 11 '14, 10:53 a.m.

What is shown when selecting Create link of Derives type ?


Dmitry Gorshenin commented Apr 14 '14, 1:40 a.m.

There is only a possibility to choose another RM artifact as a link. Other JTS applications are unable to be chosen.


permanent link
Andrey Karaulov (1861) | answered Apr 11 '14, 9:32 a.m.
 Hi Dmitry,

This is expected behavior, since "Derives From" linktype is unidirectional, while "Elaborates" links is bidirectional.
In order to check if the link you are trying to create is bidirectional you can check the presence of "reverse" link  by following steps:
1. Open project dashboard.
2. Click "Administration" button in the right upper corner and select "Manage Project Link Types" menu item.
3. On the opened page click on the linktype name.
4. In the opened dialog you will see either "No reverse link" or "Use current revers link" option.
"No revers link" means that linktype is unidirectional.

Regards,
Anrey


Comments
Dmitry Gorshenin commented Apr 11 '14, 10:00 a.m.

Hi Andrey,

thanks a lot for your tip. Indeed, the 'Derives From' link type has a 'No reverse link' option in my project area properties. I have another JTS installation, where the behavior of 'Derives From' links is bi-directional. Now I can compare the configurations and maybe find a solution. If I succeed, I will definitely post it.


Francois-xavier Panaget commented Apr 11 '14, 10:17 a.m. | edited Apr 11 '14, 10:22 a.m.

Hi Dmitry,

I am adding a screenshot of the Derive From link type in DM for documentation purposes.


The bidirectional is I believe achieve by the RM and/or DM being able to query each other for links.
I have just tried a 4.0.5 installation I have here, and you should indeed be able to see the link in RM (as Derives type) if you have created it from DM (Derives from type) and vice versa.

Regards,
François


Dmitry Gorshenin commented Apr 14 '14, 1:48 a.m.

Hi Francois,

Maybe my problem is caused by the fact that I cannot link DM artifacts from RM. I tried to add a new association to the RM project area 'Associations' section, but I couldn't add an association of 'Uses' type - the 'Provides' one is only available for the /dm application. Do you have any ideas what could be done to allow RM to see DM project areas and artifacts?

Thank you


Francois-xavier Panaget commented Apr 14 '14, 5:09 a.m.

Hi Dmitry,

The association from RM should always be shown as a "Provides" (at least on my installation)

while from DM, you can choose between "Provides" and "Uses"


Are you completely enabled the create the association?
Check if the friendship is correctly setup?
There should be an entry in the JTS consumer inbound admin page for the DM root services which matches the entry for the RM rootservices in the DM friendship admin page.
Here is what I see on my 4.0.5 installation (I have not yet tried 4.0.6).
JTS inbound consumers:


DM friends:


May be you can give add screenshots of what you see?
Else, check the jts.log, rm.log and the dm.log for potential errors ?

François


Dmitry Gorshenin commented Apr 15 '14, 2:54 a.m.

Hi François,

thanks a lot for your great answers and support. My settings seem to be correct, they are like yours. I suppose there is some internal error in our JTS installation. I wouldn't like to waste your time until me and my colleagues try to analyse logs and configuration and compare working and non-working installations.
I have only one little question. Is it possible on your installation to add DM links when working with RM artifacts? On my installation, when I try to create a link, only artifacts from other RM projects are available to choose (sorry for screenshot absence, my reputation points aren't enough yet to upload images).

Best regards,
Dmitry




Francois-xavier Panaget commented Apr 23 '14, 6:06 a.m.

Hi Dmitry,

Yes on my installation (4.0.5 and 4.0.6 now, I can add derives link from RM to DM.
Make sure that the project association is correct and that your user has appropriate permission in the DM project are to create resource links

Regards,
François


Francois-xavier Panaget commented Apr 24 '14, 4:46 a.m.

Dmitry,

Some additional comments.

From RRC, if you have specified the project association as "Provides-Related Requirements", the "Derives" type of link will not be available from RM. You will see instead "References" type.

From RRC, if you have specified the project association as "Provides-Requirements" ("Uses-Requirements from DM), the "Derives" link type will be available for you to choose.

Regards,
François.


Rosa Naranjo commented Apr 29 '14, 9:12 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

francois, do you know of a place where it is documented what project association yields what link type? and/or a place where it is documented that certain link types only show up  based on the integrations set up with RRC?


Francois-xavier Panaget commented Apr 29 '14, 1:14 p.m.

Hi Rosa,

The only place I know is:
Integrating the CLM applications and Design Management
where it says:

When creating a project association from an RM project to a Design Management project, use the "Uses Requirements" project association type -- not "Uses Related Requirements" association type. The "Uses Requirements" type enables the "Derives" link type for that project association.
François

showing 5 of 9 show 4 more comments

Your answer


Register or to post your answer.