It's all about the answers!

Ask a question

Favorites not working with RTC 4.0.3 for Eclipse 4.2.x


Denilson Nastacio (2122) | asked Oct 23 '13, 12:03 p.m.
I am trying to migrate to RTC 4.0.3 (which is RTC server level in our environment) , and everytime I double-click an item on a Favorite item, I get the following pop-up message "Windows cannot find '#//'. Make sure you type the name correctly, and then try again."

This happens to older (created prior to RTC 4.0.3) AND with queries. I am using the Eclipse 4.2.x version.
I cannot go to 4.0.4 to try for fixes since our RTC server is at 4.0.3.

This is a brand-new workspace.

I tried on all versions prior to RTC 4.0.3 (including 4.0.2) and the issue does not happen, the Favorites work.

The Eclipse version is:
Version: 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7
Build id: M20130204-1200
which comes with IBM Rational Software Architect 9.0.1
but I also tried the standalone RTC 4.0.3 with the same results.

I am using Windows 7 64-bits, in case it helps.




Comments
David Knibb commented Jan 13 '14, 6:29 a.m. | edited Jul 03 '14, 11:32 a.m.

I'm also seeing this problem.
I have RTC Version: 4.0.3 Build id: RTC-I20130517-1856,
embedded into Rational Developer for z/Series rdz90P2-I20130924_1638

Eclipse is at Version: 4.2.1.v20130118-173121-9MF7GHYdG0B5kx4E_SkfZV-1mNjVATf67ZAb7

Any update on this issue? I can add up to one query to my favourite queries, but cannot execute it.


Jane Revak commented Jul 03 '14, 8:58 a.m. | edited Jul 03 '14, 11:32 a.m.

Did anyone ever figure out a solution to this problem?  I've recently updated to RTC 4.0.3 and am seeing this problem with favorites as well.  If there is a work around, I would love to know what it is.  Thanks!

One answer



permanent link
Tim Mok (6.6k38) | answered Jul 03 '14, 11:46 a.m.
JAZZ DEVELOPER
Eclipse 4.2.1 was not supported and testing was only done for 4.2.2. There are also Eclipse patches required that are not included in 4.2.1 until later Eclipse releases.

See https://jazz.net/library/article/1295 for details of what patches to install into Eclipse 4.2.2.

Your answer


Register or to post your answer.