It's all about the answers!

Ask a question

Default data warehouse based reports always returns nothing in RTC?


Don Yang (7.7k21109138) | asked May 02 '14, 7:46 a.m.
edited May 02 '14, 7:48 a.m.
In RTC 4.0.x(tested in multiple versions), I tried to
1) create a Scrum PA
2) created a dozen of defects and tasks, set the priority/severity, and current iteration
3) run data collection jobs and it is successful
4) go to reports  and run some data warehouse based reports such as "work items by priority report"
New Work Items by Severity and Open Work Items by Type reports, it always returns:
****
This report presents historical data from the data warehouse. This data is collected by automated data collection jobs. It is possible that this chart is empty because these jobs have not had a chance to run yet.
To run the data collection jobs manually as an administrator, go to the Reports tab in the administrative web UI for the Jazz Team Server. Select the "Run all data warehouse collection jobs for all applications" link. After the jobs have completed, try viewing this report again.
It is also possible that the selected parameters did not return any results from the data warehouse.
****
The bottom will show the current iteration I set in the workitem.
If I go to Edit and I see "my team area" and "current iteration" are checked by default. If I uncheck those two settings and run the report, everything will be returned, this means data warehouse has populated the data properly.

Now if I run the same reports against JKE Banking, by default, it will always return some results. I go to edit and see the default settings are the same: "my team area" and "current iteration" are checked.

In my own Scrum PA, if I keep "my team area" and "current iteration" checked and select all priority type, I still see blank result for "work items by priority report"(I thought priority may play some role here but it is not). If I create some team areas and set the work items to the new team areas and run data collection jobs, I still see "no result found" message with default settings("my team area" and "current iteration" checked).

With the default settings only(not using edit to select/unselect anything else), why JKE Banking will always return the results but my own Scrum PA does not?
Does anyone know what fields in the workitems(defect or task) would matter for these data warehouse based reports to be able to populate into the reports by default, just as how JKE Banking works?
(manually edit the reports and select/unselect some parameters would generate the results, my question is for the default settings without any manual editing and why JKE Banking works but not my multiple PAs)

Appreciate if anyone have a successful run and share the info. Many thanks.










Comments
sam detweiler commented May 02 '14, 8:03 a.m.

what does My Team Area mean? is your userid in the team area?


Don Yang commented May 02 '14, 8:10 a.m.

Thanks Sam.
I think My Team Area mean Project Area if there is no team areas created. I tried with Project area without team areas or with team areas, the result is the same: nothing found by default


Accepted answer


permanent link
Rafik Jaouani (5.0k16) | answered May 02 '14, 8:45 a.m.
JAZZ DEVELOPER
The trend reports will only show the trend that falls between the earliest iteration start date and the latest end date depending on the selected iteration. So may you assigned work items to iterations that had already ended.
Don Yang selected this answer as the correct answer

Comments
Don Yang commented May 03 '14, 12:46 a.m.

Thank you very much Rafik for this info.
I did some more test and notice that the message in the field:
=
Iterations: Sprint 2 (1.0) (01/05/2014 - 30/05/2014)
Report Generated 03/05/2014 2:30:43 PM
Last Data Snapshot: 03/05/2014 2:30:23 PM
==
is crucial to see the default result. If we have data falling within the iteration interval, then the default will show the results. In the above result, the data snapshot is within the iteration interval hence I have got the data. I went back to check with JKE Banking, even though the iteration is already out of date but since it has data snapshot falling within the iteration, it still show the results.


Don Yang commented May 03 '14, 3:18 a.m. | edited May 03 '14, 3:23 a.m.

Hi, Rafik

I created a brand new project area and have some new workitem and then run data collection jobs and then run report " work item by priority" and others, but I failed to see the default result at all. I notice that Last Data Snapshot is not presented in the section:
About this report
which is the point. How the data snapshot got generated? isn't it from data collection job which I had just ran successfully, can you please advise as that info is crucial for me to get a default result. Thanks



Don Yang commented May 04 '14, 12:20 a.m.

Hi, Rafik
The overnight data collection jobs wont generate data snapshot as expected and I still can not see the default result when "my team area" and "current iteration" is checked(default).


In the above, since there is no last data snapshot generated, I won't have any results.
I don't have any team areas created, hence my understanding is that My team area mean Project Area and it is File Against in the work item I created. So I still am not able to get expected default report result. Am I misunderstanding what you mean "So may you assigned work items to iterations that had already ended." or there is anything I need to do further to get data snapshot generated in the default settings? Can you please advise? Thanks a lot.


Rafik Jaouani commented May 05 '14, 7:23 p.m.
JAZZ DEVELOPER

Very hard to tell by just looking at the above. If you have no team areas, then please uncheck the "My Team Areas" check box.


Don Yang commented May 06 '14, 2:32 a.m.

Thanks Rafik.

Your answer


Register or to post your answer.