It's all about the answers!

Ask a question

Does RSA Design Manager support UPIA-specific modeling tasks?

Ricky Fielding (38712) | asked Aug 19 '13, 3:23 p.m.


We've been working with DM as our primary change management tool for a few weeks, and a couple of things have come up in discussion with a colleague, This is a two-part question:

1) The "Add UPIA" context menu is gone in Design Explorer.  Is that by design? (Ha!) or is there something I should be doing to make it show up?  Most UPIA modeling can be done either by modeling in UML and sterotyping to UPIA (not ideal since many of our modelers are less-than-familiar with UML) or by using the palette, but they have been taught to use the right-click menu to build up their models.

2) The "UPIA Modeling" context menu is gone too.  Options on that menu include 1) Reorder Stereotypes, 2) Set Logical Domain, 3) Generate Resource Exchanges, 4) Generate Resource Flows, 5) PES import, and 6) PES Export.  Items 3-6 are critical for us since 3-4 are part of the modeling process and 5-6 are required for interoperability with other programs and DOD architecture repositories. 

It would be nice to know if there's a preference or property that I need to set.  Otherwise, I guess I'll submit this an enhancement request?



Ricky Fielding commented Aug 21 '13, 12:02 p.m.


One answer

permanent link
Francois-xavier Panaget (58914) | answered Aug 22 '13, 8:19 a.m.
 Hi Ricky,

I would recommend you to contact your RSA DM support team on this issue?
Which version are you using?
I have tried RSA DM 4.0.3 and the RSA DM eclipse client extension 4.0.3 and I do see:
1. The add menu is indeed not present when right clicking on a diagram on the other hand the menu is present when right clicking on a UPIA stereotyped class for example.
2. The palette and the diagram flyover add menus are presents.
3. The "UPIA Modeling" context  menu. 

Is that was your users are seeing?


Ricky Fielding commented Aug 22 '13, 5:03 p.m.

Hi Francois,

We are using 4.0.2 (our hosting provider tried upgrading to 4.0.3 and had several problems that forced them back to 4.0.2) with RSA ver. 8.5.1.  The picture below contains the versions of various Design Managment plug-ins we're using: 

INstalled DM Versions

We don't see the UPIA icons in the tree view, even though the UPIA Profile is applied and elements are stereotyped to UPIA types:

Design Explorer Tree View

And, I was wrong -- the UPIA Modeling option does show up, but only from the diagram and not from the tree view, which is not the workflow we've been trained to.  Even so, the "Add UPIA" option still doesn't show up on the diagram's context menu.

DE Context Menus

I wonder if it's just a 4.0.2 to 4.0.3 change, or if I've got something set up wrong.



Your answer

Register or to post your answer.