It's all about the answers!

Ask a question

RQM Execution Tool doesn't Accept passwordFile parameter


Leandro David (721719) | asked Jul 10 '13, 6:24 p.m.
I'm trying to use the RQM Execution Tool with the passwordFile parameter but it is not accepted.

This is the command I'm running

"C:\Program Files\IBM\Java70\jre\bin\java" -jar RQMExecutionTool.jar -tcerId=9399 -projectName="My Project" -publicURI="https://server.com:9443/jazz" -user=user -passwordFile="c:\passwordfile" -exitOnComplete=true -printResultUrl=true

And I receive this error message:

SEVERE: java.lang.IllegalArgumentException: Command line switch not found: [-passwordFile=c:\passwordfile].
com.ibm.rqm.executiontool.util.ExecutionLogger logInfo
INFO: llegal argument provided. See help for argument list and usage.


I'm running RQM 4.01 at server and the equivalent RQM 4.01 RQMExecutionTool client

I also tried using the 4.03 client and it didn't worked, received the same error


The reference to the -passwordFile parameter is stated in the RQM Execution Tool wiki  but is not listed in the reference that appears in the prompt after the command fails or when I run the -help parameter

Anyone know if this is something that will be implemented yet in next release 4.04 ?

Accepted answer


permanent link
William B Chen (3125) | answered Jul 15 '13, 9:51 a.m.
Hi,

The passwordFile parameter is not yet available. The tool can support these switches or parameters based on the rqmexectool.xml from RQM Execution Tool:

<property name="rqmUser" value="qmuser"/>
<property name="rqmPassword" value="password"/>
<property name="rqmUri" value="https://localhost:9443/jazz"/>
<property name="rqmProjectName" value="Quality Manager"/>
<property name="testCaseERId" value="1"/>
<property name="scriptId" value="1"/>
<property name="adapterId" value="1"/>

<executeTestCaseExecRecord userId="${rqmUser}" password="${rqmPassword}" rqmServerUrl="${rqmUri}" projectName="${rqmProjectName}" testCaseExecRecordId="${testCaseERId}" scriptId="${scriptId}" adapterId="${adapterId}" arguments="-exitOnComplete=true"/>

Cheers,
Will

Leandro David selected this answer as the correct answer

Comments
Leandro David commented Jul 15 '13, 1:42 p.m.

Thanks Willian.

Do you know if it is planned for the next release (4.04) ??
If yes, do you know if it will be possible to use the RQMExecutionTool 4.04 with 4.03 server or is it something that will require the updated version in server too ?

One other answer



permanent link
William B Chen (3125) | answered Jul 18 '13, 4:03 p.m.
Hi Leandro,

No problem. The option is intended to be available in 4.0.4 release. Please see this enhancement request for more information - Add support for JBE password file to the RQM Commandline Execution Tool:

https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=86068

Cheers,
Will

Your answer


Register or to post your answer.