It's all about the answers!

Ask a question

Can any one help me integrate RFT & RQM, Importing scripts from Jazz repository to RQM?


RFTUSER IBM (11111) | asked Jul 24 '13, 10:50 p.m.
retagged Jul 29 '13, 11:58 a.m. by Ralph Earle (25739)
 I am trying to install and integrate Rational Functional Tester, Rational Team Concert & Rational Quality Manager. Using Jazz Repository as shared Location.

5 answers



permanent link
Rajat Singh (59833543) | answered Jul 28 '13, 5:28 a.m.
Make sure you have proper access to the repository where you have shared the RFT scripts.
Add that location in RQM under 'Manage Project Properties':



Go to Construction->Import Test Scripts and select script type as Rational Functional Tester.
Click on Browse which would show the shared location that you entered under 'Manage Project Properties'.
Select the scripts listed there and import them into RQM.

Hope this helps!!

Best Regards
Rajat


permanent link
Georg Kellner (825375103) | answered Jul 25 '13, 8:00 a.m.
Install RFT on the machine which has to run the automated tests.
You'll have to start the adapter for RQM in the Windows Start menu.

If you create an automated test script you can choose the machine with the RQM adapter, and you'll have to give the path to the RFT testscript, which might reside in and RTC SCM workspace, in the "plain" file system, maybe in a ClearCase view or whereever you like to.

greetings georg.

Comments
RFTUSER IBM commented Jul 25 '13, 9:14 a.m.

Can I have your email address to explain exactly where I stuck?
I am unable to import scripts from Shared Repository ( in my case that is JAzz repository) into RQM. I am trying to use in RQM -> Construction -> Import test scripts and select the first radio button.


permanent link
Ara Masrof (3.2k15) | answered Jul 25 '13, 8:05 a.m.
JAZZ DEVELOPER
 The information you are looking for is available in the online help, I would start here:
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp
Rational Quality Manager > Testing > Running tests
Running automated tests

From a high level, you will need to :
Create a shared folder containing the RFT scripts and resources you want to run; this folder would need to be accessible by the RQM system
Reference the shared folder (as noted in the online help) from the Manage project properties section
Import the RFT script into RQM (Construction -> Import test scripts)
Start the RQM adapter on the RFT system
Run the RFT script via a Test Case, Test Suite...ect


Comments
RFTUSER IBM commented Jul 25 '13, 9:41 a.m.

I am trying the same thing and there I stuck. Unable to import scripts from Shared Repository ( in my case that is JAzz repository) into RQM. I am trying to use in RQM -> Construction -> Import test scripts and select the first radio button.


Ara Masrof commented Jul 25 '13, 9:50 a.m.
JAZZ DEVELOPER

When you say you are 'stuck', can you be more specific?

If you at the RQM -> Construction -> Import test scripts sections, I'm assuming you have already referenced the Shared resource location in your project properties.
You would then:
Select Rational Functional tester from the Script type drop down menu
Select the Use test resource from a shared location radio button
Then the Browse button to select the Shared resource folder where your test scripts are
 


RFTUSER IBM commented Jul 25 '13, 11:38 a.m.

I start the RQM adapter on my local machine.
After integrating RFT with RTC. I created a repository on Jazz. where I can save my scripts and when I check in and deliver it can be used by other team member.
Now what I am trying to do to use the shared scripts on Jazz repository in RQM.
So I logged in with my user id to RQM and trying to Import the test script.
That part I am not able to integrate RQM -> Jazz shared repository.


permanent link
William Chen (31215) | answered Jul 25 '13, 10:08 a.m.
Few things to keep in mind here:

The Shared Repository in question must be accessible from your RQM server. It is the shared folder which Ara has outlined above.

Also, you need to make sure the RFT adapter can connect to your RQM project area properly. You can verify the adapter connection from RQM -> Execution -> Adapter console, or IBM RFT adapter -> Adapter Console.

If you run into other issues, you can send us your reproduce steps and full error message text, then we would assist you further.

Thanks,
Will

Comments
RFTUSER IBM commented Jul 25 '13, 11:41 a.m.

I add my steps might be I am missing something, but please let me know if I have to provide anything else as I have to make this integration work
RFT is on one server and we have Local workspace too to save scripts.
But we are using our machines to access RFT.
And I integrated RTC with RFT to access work items and repository.

RQM we all are using URL as it is installed on one server.


RFTUSER IBM commented Jul 25 '13, 12:18 p.m.

or is there any way in RQM that we can enables RFT scripts without Importing them.
Will really appreciate your help!!!!!!!!!


permanent link
William Chen (31215) | answered Jul 25 '13, 1:13 p.m.
RTC and RFT integration should have no bearing on your adapter issue. We understand you access RQM project areas from browser using URLs. One key requirement here is that you need to have sufficient windows share permissions on your shared folder ("Local workspace, or the shared scripts on Jazz repository in RQM").

You must import remote RFT test scripts using UNC path. That is a requirement since we need to create references to your RFT test scripts.

Few steps for you to try next:

1) Check if RFT adapter has started successfully - You can look into RFT adapter console window for messages like these:

12:53:55 PM Starting adapter
12:54:04 PM Log in to URL https://HostName:9443/qm   <Project area: = Quality Manager Project (Quality Management)>

2) Verify if you can browse to the target shared folder from RQM server directly - You can follow these steps from Microsoft if you are not sure how to do that:

http://msdn.microsoft.com/en-us/library/windows/desktop/aa365247%28v=vs.85%29.aspx

You should be able to import RFT test scripts after completing the above steps. Hope this helps!

Comments
RFTUSER IBM commented Jul 25 '13, 10:24 p.m.

 I am new to Rational tool and I have to integrate RTC, RFT & RQM, didn't get much time to investigate and start integrating. Can you please explain me with example how the data flow in each of it? 


RFTUSER IBM commented Jul 25 '13, 10:30 p.m.

I did give the path as UNC convention when I am trying to import script in RQM, but that is not from Jazz Repository. That I did on server where I install RFT and I made server local workspace as sharable and than I tried to access script from my local machine, that worked fine. Having problem when trying to import from Jazz server: shared repository.


Is RQM adapter configuration is different from RFT adapter configuration?


Ara Masrof commented Jul 29 '13, 12:14 p.m.
JAZZ DEVELOPER

Have you created a Shared Resource Location within the Quality Manager project area (Manage Project Properties)? In an earlier response, Rajat provide a screen shot of this setting. This has to be done prior to any attempted import of a Test Script (assuming you want to use a shared location)


Ara
 


Ken Mullen commented Aug 15 '13, 2:46 p.m.

Hello:  I work with RFTUSER IBM.  I can clarify our problem by adding this:

RQM Importing the RFT test Script indicates it works, but then at run time RQM complains that same script is not found.   What could be wrong?

Note:
I understand... Screen does say the import is actually done at run time.
Don't understand... How the Import can indicate it's completed, but then at run time RQM can't find that script it imported.)

Your answer


Register or to post your answer.