It's all about the answers!

Ask a question

Websphere 8.5 DefaultApplication not available


Mingzuo Shen (13158) | asked Sep 10 '13, 7:50 p.m.
retagged Sep 12 '13, 12:08 p.m. by Laura W. Hinson (16126)

Hello!

I installed WebSphere 8.5 on Windows.

I created a new profile,

with the default applications (DefaultApplication, ivtApp, query) included.

No apparent errors. But when I try to get to the DefaultApplication

(or any application), I get 404 (not found) errors. For example:

curl -k https://hostname:9443/
Error 404: com.ibm.ws.webcontainer.servlet.exception.NoTargetForURIException: No target servlet configured for uri: /

curl -k https://hostname:9443/jts/setup
Error 404: ProxyServlet: /jts/setup

curl -k https://hostname:9443/jts
Error 404: ProxyServlet: /jts

I am new at WebSphere. Any pointers are appreciated! Thanks in advance!

My ultimate goal is to install Rational Quality Manager.



Comments
1
Karl Weinert commented Sep 11 '13, 11:17 a.m. | edited Sep 11 '13, 11:29 a.m.
JAZZ DEVELOPER

Based on your last comment below how much memory is installed on your system?
If you don't have at least 8 gigs of RAM I have found issues with the
-Xgc:preferredHeapBase=0x100000000 setting on a number of occasions.
If the applications did not deploy correctly you may need to  clear out the WAS cache.
If that is the cause I usually find it easier to just redeploy the profile and all the applications at that point.

To clarify, if you do not have at least 8 gigs of RAM you would remove the -Xgc:preferredHeapBase setting completely.


Mingzuo Shen commented Sep 11 '13, 12:42 p.m.

Thanks!!!

There is 4 GB RAM on the computer I am working on.
Now I am getting excited. After removing preferredHeapBase

and restart, / is still 404 and /jts/setup is showing me a normal looking

setup screen with a [Next] button. Now we seem to be in business.

I am going to beg our hardware/OS team here for more RAM.


1
Karl Weinert commented Sep 11 '13, 12:51 p.m.
JAZZ DEVELOPER

With only 4 GIGs of ram you should also decrease the XMX and XMS settings.
I would suggest 2 gigs you might be able to get away with 3.
That is definitely not enough for use in production though.

4 answers



permanent link
Karl Weinert (2.0k42536) | answered Sep 11 '13, 7:50 a.m.
JAZZ DEVELOPER
Hi Mingzuo,

It sounds like you have not installed the RTC applications yet.
You will need to use the WAS administration console to install the them. See below for link to instructions.
The administration console uses a different port than the applications.
I believe the default ports are as follows
Administrative console port: 9061
Administrative console secure port: 9044
You can verify  by opening the AboutThisProfile.txt found in the logs directory of the WAS profile.
...\WebSphere\AppServer\profiles\Profile1\logs

Link to the information center with the instructions deploying the applications:
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_deploy_was.html&scope=null

In case you are so inclined here is the link to setting up with Jython
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/c_admin_was_jython.html&scope=null

Comments
Mingzuo Shen commented Sep 11 '13, 12:44 p.m.

ok - jython, maybe later. Thanks!


permanent link
Benjamin Silverman (4.1k69) | answered Sep 10 '13, 7:56 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Mingzuo,

Have you set the JAZZ_HOME variable in WebSphere as outlined in Setting up WebSphere Application Server?  That error usually means WebSphere has not been configured correctly for CLM, most commonly because JAZZ_HOME has not been set.  I'd suggest following everything outlined in that InfoCenter topic and you should be ok.  Hope it helps,

Comments
Mingzuo Shen commented Sep 10 '13, 8:27 p.m.

Thanks - but it seems my problem is elsewhere, before JAZZ_HOME.

I am trying to get the DefaultApplication to work.

For testing, I created a brand new profile,

which does not have anything else, but the 3 apps:

DefaultApplication, ivtApp, query

FYI, for my JAZZ_HOME, I tried:

"file:///D:/Program Files/IBM/JazzTeamServer/server/conf"

file:///D:/PROGRA~1/IBM/JazzTeamServer/server/conf

first one with double quotes.

each time JAZZ_HOME is changed, I restarted the websphere windows service.


permanent link
Bo Chulindra (1.3k2718) | answered Sep 11 '13, 10:29 a.m.
JAZZ DEVELOPER
I think you are misunderstanding what the 3 apps (DefaultApplication, ivtApp, query) are. They are default applications created by Websphere Application Server and they are not related to RTC, RQM, or CLM in any way. Karl's answer is correct. You have not installed any CLM applications yet so it is expected that you cannot reach any of CLM's typical pages (like the Setup Wizard).

Comments
Mingzuo Shen commented Sep 11 '13, 10:49 a.m.

Thanks - but let me state my problems again.

I have a profile 1.

In this I deployed jts, admin, clmhelp and qm.

https://hostname:9443/clmhelp/index.jsp ok

https://hostname:9443/jts/setup 404

https://hostname:9443/ 404

Since I do not know what the problem is with profile 1,

I create a new profile, 2.

in this I am not installing jts, admin, clmhelp nor qm.

https://hostname:9444/ 404

My thinking is, if I can solve the 404 problem in profile 2, I may be able to solve the same problem in profile 1.


Bo Chulindra commented Sep 11 '13, 10:55 a.m.
JAZZ DEVELOPER

Ok sorry, I didn't see you mention anything about having already installed the CLM applications.

What version CLM are you installing?

And instead of making the second profile, I would suggest focusing on the first. Inspect all the logs (see here for help on finding the logs in WAS). See if there are any errors that point to what the problem may be. Feel free to post any errors here.


Karl Weinert commented Sep 11 '13, 11:11 a.m.
JAZZ DEVELOPER

Without having the RTC applications installed you will get a 404 error when attempting to access https://hostname:9444


Mingzuo Shen commented Sep 11 '13, 12:48 p.m.

We are installing 4.0.3 on WAS 8.5.
I believe we only purchased QM, so I did not install RTC.
Maybe we'll install RTC and others in CLM later.


Bo Chulindra commented Sep 12 '13, 4:40 p.m.
JAZZ DEVELOPER

Fyi, some people use "RTC" to mean all CLM apps while some others use "RTC" to mean just the Change and Configuration Management app. I believe Karl meant it to mean all CLM apps.

So I believe he's saying that even if you have not installed any CLM app, you will still get a 404 error when attempting to access https://hostname:9444/.


Karl Weinert commented Sep 13 '13, 7:58 a.m.
JAZZ DEVELOPER

Bo you are correct, I was using CCM and RTC interchangeably
I also did a quick test and even with the CLM applications installed you will gt a 404 error accessing the root url with WebSphere.
https://hostname:9444/
Error 404: com.ibm.ws.webcontainer.servlet.exception.NoTargetForURIException: No target servlet configured for uri: /

showing 5 of 6 show 1 more comments

permanent link
Abraham Sweiss (2.4k830) | answered Sep 16 '13, 2:39 p.m.
Here is what I would suggest:
1. Validate which transports the server instance is listening to.  It may be a port other then 9443
2. Check the virtualHost configuration to ensure the above transports have been configured as aliases
3. Check to make sure the server instance and applications have been started.





Your answer


Register or to post your answer.