It's all about the answers!

Ask a question

Client and server compatibility error after upgrading RTC from 4.0 to 4.0.3


Joachim Kaltenbach (111) | asked Jun 18 '13, 3:39 a.m.
edited Apr 04 '16, 3:14 a.m. by Krzysztof Kaźmierczyk (7.4k34997)

I have installed Rational Developer for System z V9.0 which contains a RTC client V4.0.3.

We have a RTC server V4.0 running.

When we try to connnect to the server from the RTC V4.0.3 client we get a message that client and server versions are not compatible and we should upgrade the client. As the client is on a newer version than the server, I think this can only mean that we have to upgrade the server.

Is this correct?

If yes, what do we have to do to upgrade the server from version 4.0.0 to version 4.0.3?

Accepted answer


permanent link
Krzysztof Kaźmierczyk (7.4k34997) | answered Jun 18 '13, 4:18 a.m.
Hello Joachim,
According version matrix compability: http://www-01.ibm.com/support/docview.wss?uid=swg21623665
Your server should be newer than client version.

You will find the instructions here: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html

Let us know if it helped for your.
Best regards,
Krzysztof Kazmierczyk
Ralph Schoon selected this answer as the correct answer

3 other answers



permanent link
Stephane Leroy (1.4k149) | answered Jun 18 '13, 4:22 a.m.
JAZZ DEVELOPER
Hi Joachim,

the behavior you're experiencing was expected (and normal) as stated by this compatibility matrix:
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/c_n-1.html

If you cannot afford to install a separate RTC Eclipse client instance (say at the 4.0 level):
for upgrading from 4.0.0 to 4.0.3, I suggest you start by reading :
- the Deployment wiki "UpgradePlanning" topic https://jazz.net/wiki/bin/view/Deployment/UpgradePlanning
- the 4.0.3 information center: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp

Regards,
Stéphane

permanent link
Michael Johnson (4416) | answered Feb 21 '17, 7:55 a.m.

Hey Joachim,

As I just learned (this morning from one of my own questions) that the client server compatibility is n-1.  However this is just for major versions (v4 to v5).  I thought it took the minor versions into account. 

This said, Stephane's and Kyrstof's answers are correct.  I just thought I would pass on the info. 

Good luck
Michael


Comments
Ralph Schoon commented Feb 21 '17, 8:10 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The clients version must be smaller or equal, the difference can go up to one major release number (N-1). If this is not achievable by development, the client connection will be rejected. There is a table in the System requirements or the Knowledgeable.

This question is almost 4 years old.

permanent link
Ken Tessier (84117) | answered Feb 24 '17, 5:02 p.m.

For reference, see Client and server version compatibility


Ken

Your answer


Register or to post your answer.