It's all about the answers!

Ask a question

Help with CRJAZ1579E error on step 1 when running custom setup


Thomas Loeber (62237649) | asked May 31 '13, 11:10 a.m.
JAZZ DEVELOPER
Configuration.
AIX 6.1 TL7
DB2 9.7.6
WAS 7.0.0.27
JTS and CCM

Anyone else seen this error or have some insight as to how to fix it?

Running the jts/setup custom setup option I get a failure as soon as I move to the first step (Configure Public URI). This is the error I am getting .....
The configuration test resulted in errors. Resolve the errors to continue. For more details, open the help system and search for CRJAZ1579E.ID CRJAZ1579E
hide details
The method getPrerequisiteServices() was called on the AbstractActivationManagerOwner for com.ibm.team.repository.service.internal.BaseServerDescriptionService when the service not activated. The method should only be called when the service is activated. If you see this error please report the problem to the Jazz Application Frameworks team, because there is a bug in the Jazz server.

Accepted answer


permanent link
Thomas Loeber (62237649) | answered Jun 01 '13, 9:59 a.m.
JAZZ DEVELOPER
Thanks to Kot's hint above, I looked in the jts.log file and found several errors like this one...
"ERROR XBM0H: Directory /usr/WebSphere/inst/7.0/derby/conf/jts/derby/repositoryDB cannot be created."

The WebSphere directory and everything under it was own by root:system. The instance id didn't have the permissions to work in the WebSphere directory. Once I changed the permission and restarted the server the error in Step 1 went away. 
Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Kot T. (1.5k11219) | answered May 31 '13, 5:56 p.m.
JAZZ DEVELOPER
Hi Thomas,
Could you check in jts.log and see if the application starts up with any error?
If you browser to https://<server:port>/jts/scr, does it show the scr xml content?

Your answer


Register or to post your answer.