It's all about the answers!

Ask a question

RTC-Client-p2Repo-6.0.6 (4.5.900) installation in eclipse-cpp-2020-06 (4.16.0)


Ankit Vashistha (125511) | asked Aug 13 '20, 1:54 a.m.
edited Aug 13 '20, 4:42 a.m.
HI,

I am trying to install RTC eclipse client 4.5.900 (6.0.6 plugin), in eclipse-cpp-2020(4.16.0) and getting the error as shown below.

Cannot complete the install because of a conflicting dependency. Softvvare being installed: Rational Team Concert Client Feature 4.5.900.v20180527_0514 (com.ibm.team.rtc.client.feature.feature.group 4.5.goo.v20180527_0514)
Software currently installed: Eclipse IDE for CIC++ Developers 4.16.0.20200615-1200 (epp.package.cpp 4.16.0.20200615-1200)
Only one of the following can be installed at once:
International Components for Unicode for Java(ICU4J) 4.4.2.v20110823 (com.ibm.icu 4.4.2.v20110823)
ICU4J 64.2.o.v20190507-1337 (com.ibm.icu 64.2.o.v20190507-1337)
Cannot satisfy dependency:
From: Jazz File System IDE Plug-in 3.3.1100.V20180502_0108 (com.ibm.team.filesystem.ide.ui 3.3.1100.V20180502_0108)
To: osgi.bundle; org.eclipse.gef 0.0.0
Cannot satisfy dependency:
From: Rational Team Concert Client Feature 4.5.900.v20180527_0514 (com.ibm.team.rtc.client.feature.feature.group .5.goo.v20180527_0514)
To: org.eclipse.equinox.p2.iu; com.ibm.teamz.zcomponent.ui.feature.feature.group [1.1.1500.v20180521_2034,1.1.1500.v20180521_2034]
Cannot satisfy dependency:
From: zComponent Ul 1.3.100.v20180314_0142 (com.ibm.teamz.zcomponent.ui 1.3.100.v20180314_0142)
To: osgi.bundle; com.ibm.team.filesystem.ide.ui 0.0.0
Cannot satisfy dependency:
From: zComponent Ul Feature Feature 1.1.1500.v20180521_2034 (com.ibm.teamz.zcomponent.ui.feature.feature.group 1.1.1500.v20180521_2034)
To: org.eclipse.equinox.p2.iu; com.ibm.teamz.zcomponent.ui [1.3.100.v20180314_0142,1.3.100.v20180314_0142]
Cannot satisfy dependency:
From: Eclipse IDE for C/C++ Developers 4.16.0.20200615-1200 (epp.package.cpp 4.16.0.20200615-1200)
To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.16.0.v20200604-0951,4.16.0.v20200604-0951]
Cannot satisfy dependency:
From: Eclipse 4 Rich Client Platform 4.16.0.v20200604-0951 (org.eclipse.e4.rcp.feature.group 4.16.0.v20200604-0951)
To: org.eclipse.equinox.p2.iu; com.ibm.icu [64.2.o.v20190507-1337,64.2.o.v20190507-1337]
Cannot satisfy dependency:
From: Graphical Editing Framework GEF 3.8.2.201301141834 (org.eclipse.gef 3.8.2.201301141834) To: java.package; com.ibm.icu.text [3.8.1,5.0.0)
Cannot satisfy dependency:
From: Eclipse Platform 4.16.0.v20200604-0951 (org.eclipse.platform.feature.group 4.16.0.v20200604-0951)
To: org.eclipse.equinox.p2.iu; org.eclipse.rcp.feature.group [4.16.0.v20200604-0951,4.16.0.v20200604-0951]
Cannot satisfy dependency:
From: Eclipse RCP 4.16.o.v20200604-0951 (orq.eclipse.rcp.feature.qroup 4.16.o.v20200604-0951) <
I am trying to install the RTC client feature in eclipse cpp 2020 version. please provide some help.
Is this eclipse version supported..?????  Any suggestions...???

Accepted answer


permanent link
Ralph Schoon (58.1k23642) | answered Aug 14 '20, 2:23 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Ankit Vashistha selected this answer as the correct answer

Comments
Ankit Vashistha commented Sep 01 '20, 7:36 a.m.

Thanks for your answer.

Your answer


Register or to post your answer.