It's all about the answers!

Ask a question

RTC 4 error: The server is currently in read-only mode because a migration is in progress


Mike Shkolnik (9809161143) | asked Oct 17 '12, 6:27 p.m.
I completed the migration from RTC 2.x to 3.x and then from 3.x to 4.x. I am able to access work items without issue and the diagnostic screen shows all ok. However, if I click on the Server tab I see the following error:

"The server is currently in read-only mode because a migration is in progress. In order to preserve data integrity, you will not be able to make changes to the server during this time."

How do I fix this?

3 answers



permanent link
Ralph Schoon (63.2k33646) | answered Oct 18 '12, 4:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Mike,

when you ran the upgrade scripts for RRC, you were provided with information that you need to run the RRC online upgrade. Have a look into the upgrade guide or the log to get the URL. I think it is

 https://<host>:<port>/rm/web/projects/migration

Run the upgrade and be patient. Once it is performed the server goes into read/write mode.

permanent link
john norris (20733944) | answered Mar 20 '13, 10:48 a.m.

Hi Ralph,

I made the mistake of running the upgrade script for Reqts management. This completes successfully but when I go to   PRECONDITION FAILED: CRRS8083E An error occurred interacting with JTS.

So I look in the rm.log and have

2013-03-20 14:43:20,014 [         http-bio-9443-exec-40]  INFO ing.server.core.repository.RepositoryAccessManager  - CRRRS9909I  The version of this build is: RRC401X, the version of current repository is: RRC400X, upgrade is required: true
2013-03-20 14:43:20,261 [         RM-Command-Executor-2] ERROR ver.core.request.async.internal.RRSTrackingCommand  - Error executing command
com.ibm.rdm.fronting.server.rrs.migration.PreconditionFailedMigrationException: JTS_ERROR
        at com.ibm.rdm.fronting.server.rrs.migration.command.RRC4000M7MilestoneUpgradeCommand.checkPreconditions(RRC4000M7MilestoneUpgradeCommand.java:174)

And  in jts.log

2013-03-20 14:43:20,045 [         http-bio-9443-exec-49]  INFO com.ibm.team.jfs                                    - CRJZS5629I The migration state of the application "4bcad490-37e2-405a-ad10-45a824795806" is changed to "ONLINE_MIGRATION_PENDING"
2013-03-20 14:43:20,247 [         http-bio-9443-exec-39]  INFO com.ibm.team.jfs                                    - CRJZS5629I The migration state of the application "4bcad490-37e2-405a-ad10-45a824795806" is changed to "COMPLETED_SUCCESSFULLY"

So the code is throwing an exception for RM.

Any ideas?

Regards,

John


Comments
Ralph Schoon commented Mar 20 '13, 10:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

John, you require a user with the right versions license for RRC Analyst. You need to log in as that user to RRC and run the online upgrade to finish the upgrade and to unlock JTS. There is a special URL you have to  open. See the help for the RRC upgrade. I am not sure if there is another way to achieve that - I don't understand your situation god enough for one thing. Support could help more if you can provide them with more information.


john norris commented Mar 20 '13, 11:19 a.m. | edited Mar 20 '13, 11:27 a.m.

Hi Ralph,

yes, I gave myself the RRC analyst license and get the same problem.

I will uninstall 4.0.1 and start again and this time just use the jts, ccm and qm upgrades. I must admit I have gone through several upgrades over the years with RTC and this time it has just not worked. I also think I am looking at the wrong notes for upgrade because the notes I am using in the help (upgrading & migration) has very little in what to do. It talks about preparation and the upgrade scripts but nothing about copying databases or running the migration pages on the web.

Certainly has not improved my impression of RTC.

John


Ralph Schoon commented Mar 20 '13, 11:28 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

John, you should be looking at http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html and run the interactive upgrade guide. We also try to provide additional info here: https://jazz.net/library/#tag=upgrading


john norris commented Mar 20 '13, 11:40 a.m.

Hi Ralph, yes I used this when I first upgraded. The problem is the questions are answered, the step pumped out, but three steps are prep (download etc) and the final step (ie the doing step) is look at upgrade and migration notes in the help.

Here is step 4.

Install the Rational solution for CLM version 4.0.1 Back to top

Install the CLM version 4.0.1 applications, but do not run the setup wizard. For distributed configurations, install the version 4.0.1 applications that correspond to the previously installed applications. For information about installing the server, see Installing by using IBM Installation Manager or Installing by using command-line commands.

Nothing about what do eg copy db's.


Ralph Schoon commented Mar 20 '13, 11:54 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have 18 Steps for JTS in a distributed Environment, DB2, WAS alone. (Which is scary and needs to be reduced). You should go through all the steps. The procedure is to do a side by side install of the old and the new version. Then you upgrade and run the scrips for the applications (JTS, some other App, the next App) the scripts copy settings and indexes over . You do not need to copy DB's except if you use Derby - which is explained too. Finally you deploy the new Version on WAS or run Tomcat and then you do the RRC online upgrade.


Ralph Schoon commented Mar 20 '13, 12:41 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

It is also a good idea to read the complete steps before starting to perform them.


john norris commented Mar 20 '13, 12:42 p.m.

This is very strange. I have always had no problems with RTC upgrades but this has really shocked me. And made me rethink use of RTC.

I uninstalled 4.0.1. So that left 4.0.RC3. I reinstalled 4.0.1 JTS/CCM/QM. Note no RM. I copied the repositories over from RC3. I run the upgrade scripts for jts,ccm and qm. Because this corrupts the web.xml files for those apps, I edited those and commented out the extra Filter node.

I can log on to admin via a browser but if I try anything with a project I get

CRJCA0150E The discovery document for the Jazz Team Server could not be read or validated. Lifecycle projects cannot be listed until this problem is resolved. For more details about the problem, click "show details." For information about resolving this problem, open the help system and search for CRJCA0150E.

While fetching the about services document from "https://centos64:9443/rm/application-about" a "404" HTTP status code was received.

So not sure what the "Discovery Document" is? Can't find anything on the error in the forum. Does anyone have any ideas?


Ralph Schoon commented Mar 20 '13, 1:52 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I don't understand what you are doing or why. The 3.x to 4.x upgrade is less complex than the 2.x to 3.x. I agree that it is desirable to make it easier however.

The upgrade process from a development Milestone such as 4.0.RC3 would be described here: https://jazz.net/downloads/rational-team-concert/releases/4.0.1?p=upgrading if it would require special steps. Please note you can only upgrade from one milestone to another or to the product by upgrading to every milestone in between.

It is also not recommended to have a production server running on a milestone.

Since you are running Derby, I assume you are not running a production server anyway, but a test system, since Derby is only supposed to be used for test systems.


john norris commented Mar 20 '13, 2:29 p.m.

Thanks for this Ralph. I did read that note that you link to a few weeks ago when I started this. Again it does not actually say much. Perhaps if you are involved in the development of the product it does not have to say much. But most of are not involved. It is like looking through some of the start scripts where named servers are coded - presumably test machines used by IBM. It still has a beta feel to it.

From what you have said there is no way of going from a milestone to a full release. Except to go through each milestone which is unacceptable.

The concern is that it does not work and I can not see what I have done that is unreasonable. Except that I have not gone through every milestone to get to 4.0.1. And the lack of information on the error messages. It is great that it gives errors but then info on how to fix them would be useful.

Actually IBM do suggest Derby for small teams and the free licenses.

Currently the only answer is to use 4.0.1 and import everything and lose history. Not a big deal but it does not show the product in the best light. And makes it hard to recommend to customers.


Ralph Schoon commented Mar 20 '13, 3:05 p.m. | edited Mar 20 '13, 3:06 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Sorry John, I have to completely disagree here. Every Milestone Build shows

Which is a good indicator and shows that normal rules don't apply to Milestone builds. Experience also tells that Milestone Builds are not for production usage, unless you are very adventurous.

And Derby does not really make a difference here, although I could agree that we should even more discourage Derby for production usage.


Ralph Schoon commented Mar 20 '13, 3:50 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Especially since express c for DB2 is available for free. 

showing 5 of 11 show 6 more comments

permanent link
Mike Shkolnik (9809161143) | answered Mar 20 '13, 12:13 p.m.
If it helps, I can send you a 38-page doc I compiled of all the needed instructions for upgrading from 2.0.0.2.8 to 4.0.1 (via 3.0.1.5). It's written for Linux 64 with MSSQL and a silent install via PuTTY, but it might tell you what step is missing.

Comments
john norris commented Mar 20 '13, 12:37 p.m.

Thanks Mike, I am using Derby, tomcat and Linux. I have added my current situation  in the previous comment.


Anthony Kesterton commented Mar 20 '13, 4:26 p.m.
JAZZ DEVELOPER

Hi John

I have been reading through the conversation here - and it was not clear to me if you had RRC 4.0M3 installed, or you did not have RRC installed and ran the rm upgrade script by mistake.

Ralph also correctly points out that migrating from a particular milestone to the full release needs to go via the intermediate milestones - that's what the dev team do on the CLM instance you see behind jazz.net so it works well).

If it is any consolation. I just ran through the upgrade of CLM 4.0.1 to 4.0.2 (I am also using Derby/Tomcat as a test setup but going from release to release) and it worked using the instructions in the help.  The first step (after installing 4.0.2 into a new directory) is to copy across the Derby database files (just a straight xcopy on Windows) and then run the setup scripts.  Final stage if you have RRC is to go to the migration page from a browser.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.