It's all about the answers!

Ask a question

Problem installing 64bit RTC 4.0.2 client and RAM 7.5.1.2 clientin same instance


Davyd Norris (2022714) | asked May 20 '13, 4:12 a.m.
Has anybody had problems installing the latest RAM and RTC clients together?

I am just setting up a new demo environment and have this error using both 32bit and 64bit IM



Weird thing is, I am sure I have the same version clients installed in my own Rational Software Architect instance :-(

Any ideas welcome

Dave

Comments
Gili Mendel commented May 20 '13, 8:22 a.m.
JAZZ DEVELOPER

Which Eclipse version is this?  Also, try to install from the server's update site (Extensions link right top corner).

The conflict is on the help plugin ... did the RAM runtime installed/running?


Francois-xavier Panaget commented May 20 '13, 9:52 a.m.

Hi Gili,
I got the same error with a IM RTC client 4.0.2 offering (Rational Team Concert - Client for Eclipse IDE Version 4.0.2 (4.0.2000.RTC-I20130222-1633-r402) ) which should come with eclipse 3.6.2.3.
Francois



Gili Mendel commented May 20 '13, 12:06 p.m.
JAZZ DEVELOPER

Note that RAM does not formally supports Eclipse 4.0.2.  

In any case, did you try to install from the RAM server (vs. IM)?


Francois-xavier Panaget commented May 20 '13, 12:52 p.m.

Hi Gili,

I did not try to install the RAM client on eclipse 4.0.2 but the RTC client 4.0.2 (eclipse 3.6.2.3).
From what I can see, when doing the reconciliation, eclipse is
Installing the RAM client plugins from the RAM server update site worked for me.
@Davyd, did you succeed in doing the same?

Thanks
Francois


Davyd Norris commented May 21 '13, 3:18 a.m.

Thanks for the reply!

I still haven't tried this approach but will let you know as soon as I do.

I'm building a CLM/RELM/RAM/BF machine with everything linked up. I'm even doing a manual RAM Tomcat install and using the existing RTC 4.0.2 instance for lifecycles.

Or dying in the attempt.....

Accepted answer


permanent link
Rich Kulp (3.6k38) | answered Jun 05 '13, 10:51 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
There is a conflict on the shared help features between RTC and RAM. They were built at different times and have different set of pre-reqs that cause the conflict.

Your best bet is to

a) Install RTC into a clean Eclipse (or use the RTC Eclipse client)
b) Using RAM's update site to install the RAM eclipse client. Don't choose help. (RAM 7512 is compatible with 3.6.2 and above including Eclipse 4) I don't know where you saw that the 7512 client was for Eclipse 3.4.2 because as of 7512 we don't support 3.4.2. If it says that I want to know so we can fix up the docs for 752 to be correct.
c) Using RAM's update to install the RAM RTC integration (it says for RTC 3, but it is compatible with RTC 4)
d) After these are installed and working, you could try installing RAM's help and see if the conflict is resolved. If not then you will need to just go without RAM help on the Eclipse client.

Rich
Davyd Norris selected this answer as the correct answer

Comments
Francois-xavier Panaget commented Jun 05 '13, 11:18 a.m.

Hi Rich,

I believe the RAM extension page (used to get the URL for the RAM client update site) is mentioning eclipse 3.4.
RamExtensionEclipsePlugin.jpg
We should probably have to update his page.
I believe this is where the confusion could come from.

From what I have seen using the Help > Install New Software... mechanism did not prevent installing the client even with the help plugins selected.
I am not understanding why IM (may via the P2 reconciler) is choking on the update of the help plugin. Any ideas?
I am interested in finding out as I am trying to document this installation issue in our CLM Deployment troubleshooting integration wiki page

Francois


Davyd Norris commented Jun 05 '13, 7:28 p.m. | edited Jun 05 '13, 7:52 p.m.

That's exactly the spot Francois :-)

I'll try installing RAM client into RSA 8.5.1/ RTC 4.0.2 without the help, but what about the RAM/RTC integration piece - the plugin shipping with the RAM extension says it's for RTC 3.0. Is there similar for 4.0 or is it built in?

I am assuming this is the piece that helps RTC and RAM 'know' which assets are in which repository and stops RTC versioning RAM assets?

UPDATE: Just installed the RAM Client into the above config and it went perfectly. As Francois said, installed help as well and Eclipse didn't complain about the mismatched packages at all. I also selected the RTC 3.0 integration and that went in too. I have to play with it all to see if there's any issues but it looks like the IM is being a bit fussy with the help packages.



Davyd Norris commented Jun 05 '13, 7:33 p.m.

BTW Rich, I have RAM installed in Apache Tomcat and it's working a treat, but I modified the installation instructions so that I could keep RAM config separate from Tomcat by using CATALINA_BASE to point to the RAM conf/war/admin files.

This should allow me to essentially just drop a new Tomcat in, or to pick up RAM and install without most of the individual steps.

My folder hierarchy now looks very similar to the Jazz folder hierarchy too.


Rich Kulp commented Jun 05 '13, 7:36 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

As I mentioned in my answer above, 7.5.1.2 RTC 3 integration is compatible with RTC 4.

As for IM, that is because IM is trying to do a complete installation with everything. Unlike P2 updater it won't selectively not install a bundle if there is one already there. It tried to install them both and they collided. It is due to a common help plugin that both RAM and RTC ar shipping, but they are not same date because RTC and RAM were built at different times.

The RAM p2 site notices the compatibility and doesn't try to install it again.

5 other answers



permanent link
VK L (8177127159) | answered May 20 '13, 5:08 a.m.
 Did you install any other Rational tool on this machine before? Error says that some of the packages are already installed. Could be that one of the software is already installed. please check.

Thanks.

Comments
Davyd Norris commented May 20 '13, 7:52 a.m. | edited May 20 '13, 7:58 a.m.

No this is a new VM with CLM 4.0.2 server installed in a completely different package structure. These are the first Eclipse clients installed on this machine.

The error appears when Eclipse is finalising - the two packages in conflict are from the two products being installed. I think com.ibm.ut.help.common_2.11.x is the one shipping with RAM. The error message reverses if I install the RTC client separately and then try to add the RAM client to the same package


permanent link
Francois-xavier Panaget (58914) | answered May 20 '13, 5:36 a.m.
Hi Dave,

Yes. I got the  same problem as well using the clients of RTC 4.0.x and RAM 7.5.1.2.
I believe this looks like a bug of the IBM Installation Manager RAM 7.5.1.2 client package.
If you have the possibility please log a PMR, so we can investigate further and create an APAR/Defect for this if needed, that would be great.
Else, you can try to use the eclipse Help > Install New Software mechanism to install the RAM client onto you RTC client pointing to you RAM 7.5.1.2 server Update site (you can get the URL by click on the  Help icon and choosing Extensions (for example: http://<host>:<port>/ram/RCPUpdateSite/).

Regards,
Francois

Comments
Davyd Norris commented May 20 '13, 7:54 a.m.

That's a good workaround Francois - I'll try that in the mean time.

I'm a Rational CTP in Australia and this is for my own VM demo images - can I log a work item here in the jazz repo rather than a PMR?


Josh Crawford commented May 20 '13, 8:31 a.m.

Hi Davyd,  It would be best to log a PMR since the problem might be with IM itself which isn't supported via Jazz.net 


permanent link
Josh Crawford (984515) | answered May 20 '13, 8:30 a.m.
 Another option is to install the RTC P2 installer into the RAM client.  You would use the same help > install new software > unzip the P2 installer and point the eclipse client to that plugin.  You can get the P2 installer from the All Downloads page.

permanent link
Davyd Norris (2022714) | answered Jun 05 '13, 12:36 a.m.
edited Jun 05 '13, 12:43 a.m.
Getting the same problem installing RAM Client into RSA 8.5.1 - RTC 4.0.2 client installs fine.

I tried the P2 installer and noticed that the update site that comes with RAM 7.5.1.2 says it's for Eclipse 3.4 clients. Both RSA and RTC are based on Eclipse 3.6, as Francois notes above.

I also noted that the RAM Client installation components from the update site contain an RTC 3.0 integration component - is there not one for 4.0?

Will this still work?

permanent link
Davyd Norris (2022714) | answered Jun 10 '13, 8:40 p.m.
Just FYI,

Ran the IM update on my existing RSA 8.5.1 install with RAM 7.5.1.1 client and it picked up RAM 7.5.1.2 client as an update, but failed with the same error as above, so it looks like the new RAM client is blocking on existing client updates as well.

I guess the only workaround is to uninstall any existing RAM client and manually update through the Eclipse update process :-(

Your answer


Register or to post your answer.