It's all about the answers!

Ask a question

RAM> upgrade failing at automated upgrade of RTC 2.x->3.0.1->4.0.2

Jeffery Hanson (1472713) | asked Apr 23 '13, 10:30 p.m.
edited Apr 24 '13, 7:49 a.m. by Joseph Pesot (61)
During our RAM upgrade we hit a snag. During the RTC upgrade we get this error. It says we have to manually upgrade the dashboards in 3.0 before finishing the upgrade to 4.0. As this process has been fully automatic until this point there is no documentation on what to do to manually to resolve this. Has anyone run across this problem? We are unable to move past this point of the upgrade.

Error messages:

CRJAZ1950I The database will now be searched for possible inconsistencies with timestamp data stored in the database. Any inconsistencies found will be repaired. Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... CRJAZ5036E One or more dashboard items (1) of the version 2 format were found in the database. This indicates that the upgrade to version 3 was not completed successfully. When upgrading to version 3, a manual step is required to migrate the dashboards after the server is started (see upgrade documentation for details). This step was either missed or did not complete successfully. If it was missed, you must abort this upgrade to version 4, complete the dashboard migration in your version 3 server, then retry the upgrade to version 4. If the dashboard migration was unsuccessful due to an error during migration, you may either call IBM support for assistance or opt to ignore the failure and continue with the upgrade. If you opt to ignore the error and continue, dashboards will continue to function, except that the problematic dashboard(s) will be permanently lost. . See the log file "F:\IBM\RAMServer\ewas7\profiles\profile1\config\cells\RAMNodeCell121204\RTC\server1\v401\jazz\server\repotools-ramccm_addTables.log" for details. Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for ""... Running post addTables for "SCM Work Items Bridge Migration Handler"... Running post addTables for "Full Text Migration Handler"... Running post addTables for "Interop WorkItem Manager Migration Handler"... Running post addTables for "Interop ClearQuest Manager Migration Handler"... The user "ADMIN" has logged out of the database "//;password=xxxxxxxx;". CRJAZ1791E **ERROR** Migration completed with errors. The imported database is in an inconsistent state and should not be used without further analysis.

3 answers

permanent link
Francois-xavier Panaget (58914) | answered Apr 24 '13, 3:58 a.m.
Hi Jeffery

This is a known problem.
Even if you are not created explicitly a dashboard the fact of logging on to the internal RAM RTC server has the consequence of creation of a dashboard and as a result prevents the automatic migration of the RTC server from 2 to 4.
The following defect is tracking the problem:
RATLC01547390 Dashboard errors while migrating RTC server from v2 to v4
The solution is outlined in the Work Item.
You need to remove the dashboard manually using the java script in the defect before performing the migration/upgrade to

Did you create a backup before proceeding with the migration as you probably will have to rollback to
Check the following WI to get information regarding backup and rollback

I hope this will help you.

permanent link
Peter Walker (168136) | answered Apr 24 '13, 8:54 a.m.
Francois is correct. You will need to first restore the RAM RTC database (don't worry about the RAM DB, that hasn't been migrated at this point). You will also need to uninstall the deployed apps --> RAM1WebApplication, ramccm, ramjts, Reinstall the setup.ear for, run the Setup again to reinstall the RTC 2002 app so you have a running RTC 2 again. Follow the steps in work item 85594 to remove the dashboard. Then update the setup.ear to and go through the steps to deploy and migrate.

Peter Walker
RAM Development

permanent link
Liviu Ionescu (13223) | answered Apr 26 '13, 1:29 p.m.

I wanted to follow up with the resolution on the issue posted by Jeff. We worked with Ben Tran from the RAM Support Group, who was very knowledgeable, very precise in directions, and really helpful. He pointed out immediately that we needed to clean the dashboard. We did some preliminary work to make sure that everything is backed up, clean, etc. then, we ran the script to clean up the dashboards. That was successful.

When we tried to re-run the migration of the databases, we ran into another problem (see error message below) indicating that we are using an old database version. After some more investigation, we decided to simply blow away the RAM related databases, we started clean with the ram.setup path for and this time around, instead of using the embedded RTC application, we pointed RAM to work with the existing JTS and RTC servers that we have in the POC (proof of concept) environment. The loss of data was minimal, and the new setup is actually much better.

At this point, everyone is working fine in the new version. Thank you for your help.

Repo Tools Provisioning using "F:/IBM/RAMServer/ewas7/profiles/profile1/config/cells/RAMNodeCell121204/RTC/server1/v401/jazz/server/conf/ramccm/provision_profiles". Jazz Foundation - Core Libraries, Version 4.0.1 (RJF-I20121109-1457) Change and Configuration Management - Core Libraries, Version 4.0.1 (RTC-I20121113-2333) CRJAZ1363I Loading the configuration from "file:F:/IBM/RAMServer/ewas7/profiles/profile1/config/cells/RAMNodeCell121204/RTC/server1/v401/jazz/server/conf/ramccm/". CRJAZ1778I This server is configured as an application. CRJAZ2558I Setting the local server rename state to false and the openServerDescriptionServiceTemporarily state to false. CRJAZ1365I The server is attempting to connect to the following database: "//;password=xxxxxxxx;" CRJAZ1364I The connection to the following database was successful: Db Product Name: DB2/NT64 Db Product Version: SQL09077 Db URL: jdbc:db2://;password=xxxxxxxx; Jdbc Driver Name: IBM Data Server Driver for JDBC and SQLJ Jdbc Driver Version: 4.14.88 CRJAZ1970I The application is configured with: Public URI: "" Jazz Team Server location: "" CRJAZ2523I Setting the global server rename state to false and the validation state to false. CRJAZ2105I Checking for a running server... Adding tables to the database "//;password=xxxxxxxx;". CRJAZ2464E You cannot directly migrate to this release because your database is from an older, unsupported release. For more details, open the help and search for CRJAZ2464E. 

Your answer

Register or to post your answer.