It's all about the answers!

Ask a question

CLM 4.0.1 upgrade - SSLPeerUnverifiedException happening in logs


1
1
Chris Ryan (15732228) | asked Apr 10 '13, 5:12 p.m.
retagged Apr 11 '13, 8:27 a.m. by Laura W. Hinson (16126)
Hello, I am setting up a staging environment for my CLM 4.0.1 upgrade (upgrading from 3.0.1.4). Following the IBM upgrade steps, I'm now at the point where I upgrade my licenses. They upgraded fine, but now when I look at my jts.log, I receive errors.

"The license keys contributed by Applications could not be discovered. Some licenses contributed by installed Appllications might not be available."
 ......
"caused by: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated"

I tried upgrading RRC, but it failed. Now when I try, it says that I already failed to upgrade it once, please consult the documentation.

Can anyone make sense of that SSLPeerUnverifiedException I'm getting?

Comments
Kevin Ramer commented Apr 11 '13, 9:54 a.m.

Accepted answer


permanent link
Kot T. (1.5k11219) | answered Apr 10 '13, 5:37 p.m.
JAZZ DEVELOPER
Are you using proxy? Could you check to see if any error in the proxy server log?

Other than the error in jts.log, do you see any problem when trying to access any of the CLM applications?

Chris Ryan selected this answer as the correct answer

Comments
Chris Ryan commented Apr 10 '13, 7:45 p.m.

We are using a reverse proxy with IHS. What log file contains proxy logs?


Also, I will install the admin application tomorrow and will then update on my findings and I there are continuing problems.

Thanks a million 


Clement Liu commented Apr 10 '13, 9:13 p.m. | edited Apr 10 '13, 9:15 p.m.

http_plugin.log in IHS_install_dir/logs


We had the same error during our last upgrade and we found the error entry in the http_plugin.log pointing to the wrong location of cert files. 


Chris Ryan commented Apr 11 '13, 8:23 a.m.

I took a look at http_plugin.log, and I see some errors for sure.  Specifically,

ERROR: lib_security: logSSLError: str_security (gsk error 408): GSK_ERROR_BAD_KEYFILE_PASSWORD

ERROR: lib_security: initializeSecurity: Failed to initialize GSK environment
...
..
...

Any thoughts?


Christian Glockner commented Apr 11 '13, 9:45 a.m.

Hi Chris,


This indicates that the password of the key database may have expired or that the stashfile which stores the password is not accessible anymore.

There is a technote that describes the situation and a way to fix it:


Let me know if this helps!

-Christian
Technical Support Engineer
IBM Rational Client Support Europe

One other answer



permanent link
Chris Ryan (15732228) | answered Apr 10 '13, 5:31 p.m.
I may be having issues because I neglected to install admin.war into Websphere.

Stay tuned...

Your answer


Register or to post your answer.