It's all about the answers!

Ask a question

RTC 3.0 not starting after trying workspace in RTC 4.0


Peter Carlsson (1122) | asked Apr 16 '13, 4:59 a.m.

Hello!

I normally use RTC 3.0 but also have a test installation of RTC 4.0. Now I started up RTC 4.0 and pointed at my RTC 3.0 workspace. It complained about version mismatch and that I should update the server to 4.0 to be aligned with the client. Now, when I try to start the workspace in RTC 3.0 again it loads for a while but then stops without showing any messages. Was something automatically updated, and how could I revert back to RTC 3.0?

Best regards,

Peter

5 answers



permanent link
Eric Jodet (6.3k5109120) | answered Apr 16 '13, 5:07 a.m.
JAZZ DEVELOPER
 Hello Peter,
I would think that you someway corrupted your Eclipse wks.
May you please share here the .log file that you should find in:
<workspace_directory>/.metadata/
?

Thanks.
Eric.

permanent link
Peter Carlsson (1122) | answered Apr 16 '13, 5:52 a.m.

Hello!

Sorry if I double/triple post, but I don't see my own comments.

The log file is rater big and I don't know how to attach a file. Could you please tell me how or is it OK to just paste it in the replay?

/Peter


Comments
Eric Jodet commented Apr 16 '13, 5:55 a.m.
JAZZ DEVELOPER

 Hello Peter,

you may want to e-mail me the .log as a zipped file.

Thanks.
Eric.


Karl Weinert commented Apr 16 '13, 8:53 a.m.
JAZZ DEVELOPER

Move the original .log file to a temp location then reproduce the problem.
That should create a new .log file with a lot less data in it which may make it small enough to paste into your question.


permanent link
Peter Carlsson (1122) | answered Apr 16 '13, 6:04 a.m.

Hello Eric!

Thanks for your help!

What address do you want me to send to?

This is weird. I have to try several times to reply to this question before I see my own replies.

/Peter


Comments
Eric Jodet commented Apr 16 '13, 7:10 a.m.
JAZZ DEVELOPER

 Hello Peter,

address is eric_jodet@fr.ibm.com

Thanks.


Eric Jodet commented Apr 16 '13, 9:04 a.m.
JAZZ DEVELOPER

 received the log - the interesting part being:

!ENTRY com.ibm.team.process.rcp.ui 4 0 2013-04-16 10:22:13.840
!MESSAGE Error logged from Process RCP UI: 
!STACK 0
com.ibm.team.repository.client.ServerVersionCheckException: Client and server versions do not match.
at com.ibm.team.repository.client.internal.TeamRepository.checkServerVersionMatches(TeamRepository.java:1722)
(...)

now looking in the code: there must be some file in the metadata dir (?) where we store some compatibility information


permanent link
Ralph Schoon (59.0k23642) | answered Apr 16 '13, 8:26 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I had the same effect once and I think I abandoned and recreated the workspace.


permanent link
Eric Jodet (6.3k5109120) | answered Apr 16 '13, 9:49 a.m.
JAZZ DEVELOPER
 Peter,
I am sorry but I did not find whether or not we were storing some compatibility information in the eclipse wks.
However - there is some eclipse wks corruption here.

I would:

- add the scenario and .log

- meanwhile, as suggested by Ralph, use another wks

Thanks.
Eric.

Comments
Peter Carlsson commented Apr 17 '13, 3:55 a.m.

Hello!

As you suggest I have opened a defect (https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=261103) and also done what Ralph suggested. Now I am back on track thanks to both of you.

Thanks for all the help!

/Peter


Eric Jodet commented Apr 17 '13, 4:20 a.m.
JAZZ DEVELOPER

 looks good Peter.

Glad you're back on track!

Eric.

Your answer


Register or to post your answer.