It's all about the answers!

Ask a question

Jazzmon startup problem, url name vs IP address, help!!


sam detweiler (12.5k6185201) | asked Dec 13 '13, 8:09 a.m.
edited Jan 27 '14, 2:33 p.m.
 So, back to using Jazzmon, first time at this company. 

seems our url name causes a problem (with or without '<url>')
SERVER_URL_LIST=https://xxyyzz.intranet.xx.com/jts

but if I use the IP address all is ok 
SERVER_URL_LIST=https://10.153.104.35/jts

failing output below

E:\rtc\JTSMon_4.0_RTC3.0GA>java -jar JTSmon.jar  monitor
Output directory exists already (e:\temp\JTSMonRuntime)
Do you want to delete existing directory ?(y/n):
y
<localHost name="xxyy958751"
description="(auto-generated)"
architecture="amd64"
os="Windows 7"
osVersion="6.1"
bundleVersion="3.0_GA"
/>

Properties loaded from E:\rtc\JTSMon_4.0_RTC3.0GA\.\jm.properties

Please enter password:
xxxxxxxx
Created thread 1, starting....
Created thread 1, starting....
2013.12.13,08:03:55,929 [CounterServiceSequence_1:ServerMonitorSequence_1] Task:
 ServerSetup
2013.12.13,08:03:55,931 [CounterServiceSequence_1:ServerMonitorSequence_1] Setti
ng up User (samuel.detweiler@xx.com) password(***) for stream (Stream)
setupTeamPlatform: startup
2013.12.13,08:03:57,981 [CounterServiceSequence_1:ServerMonitorSequence_1] After
 startup, platform users running: 1
Dec 13, 2013 8:03:58 AM org.apache.commons.httpclient.HttpMethodDirector isAuthe
nticationNeeded
INFO: Authentication requested but doAuthentication is disabled
Dec 13, 2013 8:03:59 AM org.apache.commons.httpclient.HttpMethodBase processCook
ieHeaders
WARNING: Cookie rejected: "$Version=0; LtpaToken2=U2cX05wCMv/iHUU+N+tbdM0EOMygG7
ISPAdpBolbk33oxEjBaLJy6anANFqJisrVhwuSpi1ZA4Jeoel35J87eNhCp2MAwAoz9chD3oWu1UZIVX
tiEthAzN4FmW85+JacuQnSmRcBWfrUMIa8lyxqE07/T0LERSGJryWOo6IyL1BntWmIb4fWz880yCC9WM
Gx8dSu5m070DZGODg5Q4TzWvqmHfmT+CR2EvNdf5rxWeh1ULmMFtKNscOig3oRodbta3mTtiBoOrUJXC
UWkrxhB6lVY/SzhdGY9g1G6uiBDttIzaxuzQAZZ+7Hevg43QojR3D6i5iJVespTDj37MadF3l5MCVyo2
WYYi0L0fGew/r+1cz/YWdHT6+5nu74EhXD80NOfwqbKulFRO8pw6pfjw4164g2+7H+Biso8Bzbx4Rd7l
bfY7vo+4RrhSMG5Kj4mGBVKRN9hR2EGD3srln83OmQQ70BzlCjhkf4R/tYFRdeB4VhgSMUM+JhhFHllM
n1M2Sx+CarjClGJDGule/FW3AdKuKMNpHAPX03QlsPlU8/02Mxr679IH/rti5EvUerN8ICj97ovYMorh
jGKrRWNEhmZkGGX/zJwNQKfHkm8Lpb/6VyPMEe/SJWBe+mLFLnaxbx2/zVERyM4j/h7v0ELOrZSReka9
FtUXdbk1Lv8iasDKyrYWdfWFf8wDQGqVos3JQE3TMIb+/bIQ4gdGfRSQ==; $Path=/; $Domain=.xx
.com". Domain attribute ".xx.com" violates RFC 2109: host minus domain may not contain any dots

2 answers



permanent link
Dave Schlegel (331157) | answered Dec 13 '13, 3:57 p.m.
JAZZ DEVELOPER
If it is failing with the "<url>" tag added to it (to suppress any preprocessing of the URL you provide so it doesn't add default ports or contexts for any reason) that suggests the issue isn't directly in the JTSMon code but in lower levels where the host name is being misparsed to split off the domain (.com) incorrectly.

If you set the debug property in jm.properties could confirm the host name being used to enter communications layers

      DEBUG_TASK_LOG_LEVEL=FINER

I just tried out this sort of  url list against my local copy of JTSMon

      SERVER_URL_LIST=xxx01.rtp.city.ibm.com/jazz,xxx.rtp.city.ibm.com:9443/jts

and it does fine with the multiple dots and starts monitoring for me. Might be some additional communications layer involved in your local network ?



Comments
sam detweiler commented Dec 13 '13, 5:08 p.m.

sent u the log and the prop file 


sam detweiler commented Jan 22 '14, 4:05 p.m.

were u able to look at the log?  


I can repeat this.. use the ip address all is well, use the url it fails
After startup, platform users running: 1
2014.01.22,15:59:13,563 [CounterServiceSequence_1:ServerMonitorSequence_1] Exception during Task(ServerSetup): AuthenticationException, Message: com.ibm.team.repository.transport.client.AuthenticationException: CRJAZ0105I The request for the URL "/jts/service/com.ibm.team.repository.common.internal.IRepositoryRemoteService" was denied.  The status is "Unauthorized".

if I put that url in my browser I get error 500 back .

need to get jazzmon going


permanent link
sam detweiler (12.5k6185201) | answered Jan 27 '14, 2:33 p.m.
 help.. still need help here

debug=finer still returns the same

Jan 27, 2014 2:25:13 PM org.apache.commons.httpclient.HttpMethodBase processCookieHeaders
WARNING: Cookie rejected: "$Version=0; LtpaToken2=jCXjG3gH5bWsisvU3ybf9E+hR5C5JNDv2A50nexbs2ZUSz49JT4yzeCrxmgxIAPIEDTVUZ/nMWCUj3ddcdvae6BT2WCRsDMDOrHdtNY7dRlPF5I1XN8fA4hU1bpFT+czp70qORO8H4oMPWReiT9sJ+O5Jaa6FgOJNPNZR/JIOCCGtXProrav8G5fpfNPUi6yEcgW0t5+8GTLAUJsa+36XSiQJPHWRn/VB0BlkN/3XnGNOUksbjtvdzRXS5aSVQ+cD284ar/gR5z7cKcXB8zrVC6G7R3GmoPJATV54A2tlsChKvmKxrjL5i8HmwCiDJ7yF94IiieV1L6KI7Hupc9td7CR9UrGThjC72yOvtMLF9w7dC1vPm6wayY0SMWi9XNIo238nkqlkpSvhdpOVgOgJp4tfsFlP606XXSL1sJ95RjfUPqGDBav8sylUoKj3i3YP14BDSP5PTuNBDDRpUozvR5IQoKJ5fj7CGgaCrOfWH8R1//ZX4ZvpzyxYQkale8WxsqbuID0uJd1ncNUlWxwCNYVqVa1VeiULanBNFu63DB7zfviC/XAjgaXPe6tJ6y3RLmAUXWvi5Vj69qEw3bCPnw3VfsKqM2g1l6reSiwDE4G2ESCCHBT0RKQwD0ffVIcF3npz7JknAeggWtrq8xkMYC48iGWE7WDg0nzXgJvj51ob5B90pj24yWWpKjuAEEauHphWkAtvOGsOGH22MbU0g==; $Path=/; $Domain=.xx.com". Domain attribute ".xx.com" violates RFC 2109: host minus domain may not contain any dots

sounds to me like there is a name parsing problem as the domain ends up with the leading '.' 

Comments
sam detweiler commented Mar 07 '14, 10:50 a.m.

 help, still need help..


I have tried a couple things, without success..  I don't see any unusual web requests/responses in the web uri to this dns name..

when I use the IP address jtsmon works, when I use the dnsname, it fails..

they are going to change the IP address soon, and I need to get this resolved.. 

Your answer


Register or to post your answer.