It's all about the answers!

Ask a question

How do I access Workflows configuration in Project Area from the WebUI after removing pre-defined Resolutions?

Michael Prentice (622913) | asked Jan 26 '13, 6:56 p.m.
edited Jan 26 '13, 7:26 p.m.
During the configuration of our project area (in RTC 4.0.1), I removed the 'Works for me' and 'Works as Designed',  resolutions (under Project Area -> Work Items -> Workflows -> Resolutions) at the request of our project leadership. I did not previously remove them from any of the lists in the Actions table as I had seen the product handle renaming those entries automatically. I figured that it would also automatically remove them.

After saving the changes, I immediately got an error about 'name' being null. Then when I scrolled down and looked at the Actions list (previously full of entries, mostly the defaults for Formal Project Management Process), it was completely empty. It appears that one (or more) of the deleted resolutions was used by one or more Action Resolution lists.

At the time, I could not remember exactly which one of the predefined entries that I had removed (I had also removed about 5-6 entries that we had recently added, but not used). I tried to get more information about the error, but I could not find anything more helpful in Chrome's Developer Tools beyond the same error message ("Uncaught TypeError: Cannot read property 'name' of null"). I navigated away from the page to try and check the server diagnostics and other areas for information (which I did not find).

Upon returning to the Project Area -> Work Items configuration, I found that clicking on 'WorkFlows' in the WebUI now does nothing. It appears to be impossible to open it. As this is the primary (only?) way of fixing the problem, I am now stuck and I can no longer modify the Workflows.

How do I resolve this? Or how do I find out more information about the problem?

Accepted answer

permanent link
Eric Jodet (6.3k5111120) | answered Jan 28 '13, 9:42 a.m.
Hello Michael,
(glad you fixed your issue)
I generally use the Eclipse Client when customizing a Project Area.
If you can reproduce your original issue consistently, feel free to open a new defect against Process / WebUI Component using the link below.

Michael Prentice selected this answer as the correct answer

One other answer

permanent link
Michael Prentice (622913) | answered Jan 26 '13, 7:15 p.m.
I finally got this working again by using the Eclipse plugin to re-add the 'Works for me' and 'Works as Designed' Resolutions. But it looks like any modification of the Workflows by the Eclipse plugin might fix this issue (it appears to be smarter than the WebUI). 

I was able to go back to the WebUI and found that neither was listed under any of the Actions as a possible Resolution. So the Eclipse plugin must have removed the bad entries that the WebUI left behind. Because I was then able to remove both of the 'Works for me' and 'Works as Designed' Resolutions again and no longer saw the errors.

If someone from the RTC team could try to reproduce this and open up a defect for this behavior, it would be appreciated. I certainly don't want anymore else on the team hitting this in the future, certainly not after deployment.

Your answer

Register or to post your answer.