It's all about the answers!

Ask a question

RTC: Modify workitem templates


0
1
Katrin Heymann (19823959) | asked Jan 16 '13, 9:27 a.m.
We have created a workitem template.

Now we want to change some information in the existing template. Is it possible ?

Comments
Siegfried Österreicher commented Jul 11 '16, 7:01 a.m. | edited Jul 12 '16, 1:27 a.m.

Hello,

any plans to add a WorkItem Template change/update dialog to RTC to give a better possibility to update the WorkItem templates ?

Thanks in advance.
Siegfried


Ralph Schoon commented Jul 11 '16, 7:23 a.m. | edited Jul 12 '16, 1:27 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would suggest to create a new question instead of posting to a question that was answered 3 yeas ago.

Accepted answer


permanent link
Henning Sternkicker (40626) | answered Jan 16 '13, 1:21 p.m.
JAZZ DEVELOPER
If you want to modify the work item template that you have created, follow these steps:

1. Export the work item template to an XML file. In the Eclipse - Client from the file menu Choose "Export" -> Team -> Work item template.
2. Use an editor to edit the file that you exported. The work item template itself has an identifier and a name of the template in the beginning of the XML (<dc:identifier> and <dc:title>) if you want to keep your original work item template in the project area you have to change this too for your modified template, otherwise the original template will be overwritten on import time.
3. Import the work item template again.

Hope that helps,

Henning
Katrin Heymann selected this answer as the correct answer

Comments
Nate Decker commented Aug 15 '13, 1:44 p.m. | edited Jul 12 '16, 1:26 a.m.

I tried doing exactly as suggested in the accepted solution. However, I receive an error, "Cannot save the work item template on the server."

What permissions are required to do this?


Clement Liu commented Aug 15 '13, 7:49 p.m. | edited Aug 15 '13, 7:54 p.m.

Hi,  @zetareticuli,



Creating a work item template

Before you begin
To share the template with members of a project area, you must have a role that has permission to modify the project area process specification. 

4 other answers



permanent link
abhishek patti (9134) | answered Jan 16 '13, 10:20 a.m.
JAZZ DEVELOPER
You can open the template.xml file in Rational Team Concert or any xml editor (such as notepad++) and change it

Comments
Erwin Kunz commented Jan 16 '13, 10:47 a.m.

Can you give some more info where to find this template.xml


permanent link
Guido Schneider (3.4k1383110) | answered Jan 16 '13, 10:43 a.m.

You cannot update template with the UI. You only can reinstantiate the workitems to a new template.

What we are doing:

We have the workitem structure, a Template is based on, in the project area in a special category/team and iteration. This WI's we can modify and recreate a template after editing. The special category/team and iteration is usefull, so you can build your own plan, where you only see this workitems you are using to build templates.

- Special Team: "Templates"
- Special Category: "Templates" associated to the Team "Templates"
- Special Iteration. "Templates"
- Special Plan: "Template Management", Owner: Templates, Iteration: Templates, Treeview

The Planned For and the Category value will be asked when you do "Create from Template.."


permanent link
Geoffrey Clemm (30.0k23035) | answered Apr 22 '13, 12:31 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
My first choice would be to instantiate the work item template in some "template editing" project area, make modifications to the resulting work items, and create a new (version of the) template from the modified work items.   If you are producing successive versions of the template, then I'd just keep using the same work items, and each time you want to make a change to the Template, modify those work items, and create a new (version of the) template from those work items.

Editing the XML for the template is possible, but I'd keep that as a last resort if for some reason the above approach does not work.

permanent link
Nate Decker (37813058) | answered Aug 19 '13, 7:46 a.m.
I was able to update the temlate later the same day where I made my post above. We did originally think it might be a permissions issue so we tried to do it using a user account that had essentially all permissions. It didn't work for that account either. When we did finally get it working, there didn't appear to be any special changes that had occurred in order to fix it. It's a mystery as to why it didn't work initially and began working later.

Your answer


Register or to post your answer.