It's all about the answers!

Ask a question

Error fetching user registry information. Please check your user registry configuration.ID CRJAZ1533E


0
1
ANANG PHATAK (111) | asked Dec 12 '12, 1:54 p.m.
retagged Dec 13 '12, 1:55 p.m. by Bo Chulindra (1.3k2718)

I am trying to fix this issue and I am at a loss as to what is wrong. I keep getting Forbidden, Missing License errors when update work items in Jazz.

When trying to edit active user information I get "Error fetching user registry information. Please check your user registry configuration.ID CRJAZ1533E" errors.

There are no ccm.log file generated! and Tomcat log files do not show any errors.

I can modify and archive users from JTS, but JTS and CCM seem to be out of sync.

In CCM, I can see ccm_user but cannot see details, the same user is missing in JTS (active or archived).

All licenses seem correct, and Consumers (Inbound) shows ccm_user as trusted for jazz application.

Any help is greatly appreciated!


Comments
Bo Chulindra commented Dec 13 '12, 9:55 a.m.
JAZZ DEVELOPER

What version JTS and CCM are you using? Are you using LDAP? Are your JTS and CCM on the same server? Are there any errors in your jts.log?

If you run the diagnostics (jts/admin#action=com.ibm.team.repository.admin.serverDiagnostics and jazz/admin#action=com.ibm.team.repository.admin.serverDiagnostics), do you see any errors?


carlos roberto commented Dec 13 '12, 3:01 p.m.

I am facing the same issue.
My JTS and CCM are in the same machine and not using LDAP. When I run diagnostics for JTS or CCM get no errors,
The details link for this error shows the following
"https://<server>:9443/jts/service/com.ibm.team.repository.service.internal.
IExternalUserRegistryRestService/isExternalRegistryWriteable"
on the JTS is not authorized. There may not be a functional user configured
for the oauth consumer, or the functional user that is configured does not have
sufficient privileges to perform the requested operation. Connection Error: null


Bo Chulindra commented Dec 13 '12, 3:09 p.m.
JAZZ DEVELOPER

@carlosl: what versions are your JTS and CCM?


carlos roberto commented Dec 14 '12, 9:00 a.m.

Im am using version RTC 3.0.1


Sathish Kumar B commented Feb 11 '13, 7:15 a.m. | edited Apr 26 '19, 5:47 p.m.

Hi Anang,

is the below error got resolved for you.

"Error fetching user registry information. Please check your user registry configuration.ID CRJAZ1533E"

2 answers



permanent link
Saurabh Malhotra (15231617) | answered Mar 31 '13, 4:17 p.m.
edited Mar 31 '13, 4:19 p.m.
 I just got this same error as well. However it was caused mostly due to my own error. I was cleaning up my server and archiving unwanted projects and users. After archiving the following users: (ccm_user, jts_user, lpa_user) I started seeing this error in many parts of RTC and Jazz.

So there you have it, if you archived these users, this will cause problems and you need to unarchive them. Might not resolve everyone's issue but I thought it would help save someone 30 minutes of head ache and retracing their steps.

The follow up question is, if we shouldn't archive these users, why is it allowed? :)

permanent link
Don Yang (7.5k2195130) | answered Mar 31 '13, 8:28 p.m.
Anang, Unarchive ccm_user from jts/admin>user menu should resolve the issue for you. You should not archive any functional ids: jts_user, ccm_user, qm_user, lpa_user etc).

Comments
Ralph Schoon commented Apr 26 '19, 5:56 p.m. | edited Apr 26 '19, 5:59 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The answer to your question is, that the system can not protect itself from administrators. Users with JazzAdmin repository role should know what to do and what not. Archiving functional users is not something you should do and the user ID's are obvious enough.

If, as an administrator, you delete files you should not delete and the server stops working, it is the same issue. The system can not protect itself from an administrator.

Your answer


Register or to post your answer.