It's all about the answers!

Ask a question

What are the Implications of having RQM 3.0.1.X with JTS 4.0.1


Srikanth Bhushan (16942634) | asked Dec 12 '12, 7:46 a.m.

Hi,

What are the implications of having RQM 3.0.1.x with JTS 4.0.1?

Is it supported, has anybody tried using different versions of JTS and applications (RQM, RTC, RRC).

Is there any general guidelines and considerations for RQM and JTS version compatibility?

If we just upgrade the JTS from current 3.0.1.X to 4.0.1 keeping RQM on 3.0.1.X, how does it affect the integration of RQM with CQ and Reqpro? Does it involve any rework or can we carry the integration as it is with only JTS upgrade

Any feedbacks are much appreciated.

2 answers



permanent link
Jerry Shengulette (63914) | answered Dec 12 '12, 10:49 a.m.
JAZZ DEVELOPER
Deep down in https://jazz.net/library/article/832/ note this comment:

"Although a mixed 3.x and 4.0 environment is supported, for compatibility with JTS 4.0 you will need RQM 3.0.1.3 and RRC 3.0.1.4. "



Comments
Srikanth Bhushan commented Dec 12 '12, 11:10 a.m. | edited Dec 13 '12, 2:33 a.m.

Thanks Rosa, Jerry,

very helpful liks. I am still looking at some explicit answers.

We are on RQM 3.0.1.3. The compatibility XL matrix in the WI is still shown as draft. Is it still being tested and is there an official publication of this matrix?

Also is there any impact on existing RQM Integrations with "only" JTS upgrade to 4.0.1 keeping RQM in 3.0.1.3 as it is.

Any other customers using this mixed combination ?


1
Rosa Naranjo commented Dec 12 '12, 11:38 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Hi,
(1) don't worry about the draft status, (2) there is no official publication of this matrix.  The information is used to populate the infocenter and other Jazz.net articles.

I cannot comment on any customers using this mixed combination.  But, we typically recommend using a staged approach for upgrading all the applications.  however, eventually folks will upgrade their applications.  Is there a reason that you are leaving RQM at 3013 and only upgrading to 401.  The bulk of the reasons to upgrade to 401 is from an application feature perspective. 

I am not sure about the impact on integrations, but I don't think are any.  The System requirements for 4.0 and 4.0.1 list information on QM integrations supported but I believe that those integrations relate to when QM is at 4.0 or 4.0.1.  If you leave QM at 3013, I assume that the integrations supported would have to be those that were supported at the 301x level. 

I don't believe we test mixed version environment + integrations.


Srikanth Bhushan commented Dec 13 '12, 1:39 a.m.

We have to upgrade to JTS 4.0.1 to support the upgrade of Insight 1.1.1.1 and this is a kind of staged upgrade since we dont want to upgrade everything once.


permanent link
Rosa Naranjo (2.8k11420) | answered Dec 12 '12, 9:41 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Srikanth
When looking for compatibility  information between JTS and the applications, I typically refer to these 2 workitems along with the information we publish in the Interactive Upgrade Guide located in the 4.0 or 4.0.1 infocenter .

Confirm supported paths for upgrading to CLM 2011 fixpacks and CLM 2012 (174745)
Confirm supported paths for upgrading to CLM 2012 fixpacks, mod packs and CLM 2013 (218962)

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html

Your answer


Register or to post your answer.