It's all about the answers!

Ask a question

using SCM CLI in OS X Mountain Lion


Murray Reid (1111) | asked Nov 07 '12, 1:44 p.m.
retagged May 25 '13, 4:32 p.m. by Scott Rich (57136)

I have not tried using SCM CLI prior to Mountain Lion upgrade, so I dont know if it is specific.

Attempts to run scm on OS X , the following message appears:

'-bash: ./scm: cannot execute binary file'

tried running lscm., the following message:

'./lscm: line 5: ./../../client/eclipse/jdk/jre/bin/java: No such file or directory.

tried running scm.sh, same message as lscm.

Modified scm.sh to remove path qualification to java.

Also copied system JRE into location referenced in error messages.

in both cases, get Null pointer exception ( in VersionStringComparator.java:71 )

Has anyone successfully run a command line in OS X Mountain Lion?

I need a working CLI to enable continuous integration server using Jenkins on OS X.

Any advice is greatly appreciated.

Thanks

2 answers



permanent link
Tim Mok (6.6k38) | answered Nov 07 '12, 2:24 p.m.
JAZZ DEVELOPER
RTC doesn't ship with a JRE and Lion doesn't include one by default.

Workaround: Install a Java Runtime Environment on Mac OS X in order to run Rational Team Concert

Comments
Murray Reid commented Nov 07 '12, 3:01 p.m.

I have JRE version 1.6 and I installed JDK version 1.7 as well.

RTC client application runs fine on OS X 10.8. It is only the scm command line stuff that does not.


Tim Mok commented Nov 07 '12, 3:19 p.m.
JAZZ DEVELOPER

Sorry, I didn't see that you already tried different VMs. Can you provide the command that you're trying to use and the full error output? It appears your VM is correct if you can get as far as that error message.


Murray Reid commented Nov 08 '12, 7:17 a.m.

Was running a status command

./scm.sh status

The entire error output is too big to allow post here.

Can I email it to you?

Thanks for looking


permanent link
Murray Reid (1111) | answered Nov 08 '12, 9:29 a.m.

I deleted the 1.7 jdk from the system and things began to work properly using the scm.sh script.

I had to modify the java path in the script to refer to the system /usr/bin/java   which appears to be a 1.6 jdkl

Thanks for your suggestions and sorry for the UBF 


Comments
Tim Mok commented Nov 08 '12, 10:12 a.m.
JAZZ DEVELOPER

I'm glad that it all worked out in the end. If you are interested in using Java 1.7, there is a work item requesting support.

Support for JRE 1.7 (221962)

Your answer


Register or to post your answer.