I'm seeing the following in logs. What does this mean? Is it a problem? CRJAZ1972E "com.ibm.team.workitem.service.internal.WorkItemRepositoryService" service failed to activate
I'm seeing the message,
2012-09-03 18:07:16,346 [jazz: AsynchronousTaskRunner-2] ERROR com.ibm.team.process - CRJAZ6016E:
CRJAZ1972E "com.ibm.team.workitem.service.internal.WorkItemRepositoryService" service failed to activate because service that it depends on "com.ibm.team.workitem.service.IWorkItemServer" failed to be activated
in my logs. What is the cause of this? Does this cause any problems?
2012-09-03 18:07:16,346 [jazz: AsynchronousTaskRunner-2] ERROR com.ibm.team.process - CRJAZ6016E:
CRJAZ1972E "com.ibm.team.workitem.service.internal.WorkItemRepositoryService" service failed to activate because service that it depends on "com.ibm.team.workitem.service.IWorkItemServer" failed to be activated
in my logs. What is the cause of this? Does this cause any problems?
One answer
This message is not a problem. It can be ignored.
Here's an explanation.
Every few seconds an asynchronous task, ProjectAreaChangeListenerRunningOnAllNodesTask, is started that tries to establish a com.ibm.team.process area change listener. The attempt to start the project area change listener fails with CRJAZ6016E because
CRJAZ1972E "com.ibm.team.workitem.service.internal.WorkItemRepositoryService" service faild to activate becuase a service that it depneds on "com.ibm.team.workitem.service.IWorkItemServer" faild to be activeted
For the first few tries, the WorkItemRepositoryService won't start because, a service it depends on com.ibm.team.workitem.service.IWorkItemServer isn't started. Eventually, com.ibm.team.workitem.service.IWorkItemServer is started by another part of the code.
The next time the server tries to start WorkItemRepositoryService it too starts.
There is a defect that is tracking this issue.
CRJAZ6016E:Exception occurred attempting to load project area change listeners when starting 4.0 server (231588).
Here's an explanation.
Every few seconds an asynchronous task, ProjectAreaChangeListenerRunningOnAllNodesTask, is started that tries to establish a com.ibm.team.process area change listener. The attempt to start the project area change listener fails with CRJAZ6016E because
CRJAZ1972E "com.ibm.team.workitem.service.internal.WorkItemRepositoryService" service faild to activate becuase a service that it depneds on "com.ibm.team.workitem.service.IWorkItemServer" faild to be activeted
For the first few tries, the WorkItemRepositoryService won't start because, a service it depends on com.ibm.team.workitem.service.IWorkItemServer isn't started. Eventually, com.ibm.team.workitem.service.IWorkItemServer is started by another part of the code.
The next time the server tries to start WorkItemRepositoryService it too starts.
There is a defect that is tracking this issue.
CRJAZ6016E:Exception occurred attempting to load project area change listeners when starting 4.0 server (231588).