It's all about the answers!

Ask a question

Password issue while upgrading to jazz 4

Ad Smeets (111) | asked Apr 28 '14, 10:00 a.m.


We are working on an upgrade from JAZZ to JAZZ 4.0.6.

All preparation seems fine but while executing the upgrade script we get a message that an invalid password is provided while accessing the database.

·         We are using CCM anden RQM.

·         The database (SQL) is on the same server as the Jazz applications.

·         JAZZ works fine

·         Access to the database with Microsoft SQL Server Management Studio is OK.

·         JRE is upgraded to JRE 7

·         sqljdbc4.jar is used

·         We tried the upgrade form teh server

·         We tried the upgrade from a remothe machine

I think it is a simple issue. Does someone have a possible solution for me?

Philippe Chevalier commented Apr 28 '14, 11:02 a.m.

Invalid password to the database may mean that the is not providing the right user name and password.   Cause: The updates of the configuration files is not being executed and that the process is trying to connect to the database using the default files, which setup for the default connection to the Derby database, not your SQL server.

Which upgrade script are you executing? and what output did you get when the process executed the upgrade configuration files?

2 answers

permanent link
Ad Smeets (111) | answered Apr 29 '14, 2:57 a.m.

Thanks for the quick reply.

Below the details from the log file of the script showing the details and the script used. The database confirms that the wrong userid or password is provided.


2014-04-28 09:29:08,003 Repo Tools
2014-04-28 09:29:08,019 java.version=1.6.0
2014-04-28 09:29:08,019 java.runtime.version=pwi3260sr15-20131017_01 (SR15)
2014-04-28 09:29:08,019 Provisioning using "C:\JazzTeamServerv4\server\conf\jts\provision_profiles".
2014-04-28 09:29:08,113 repotools-jts -addTables
2014-04-28 09:29:08,128   Jazz Foundation - Core Libraries, Version 4.0.6 (RJF-I20140130-1407)

2014-04-28 09:29:08,144
 To submit questions about issues, go to the forum at
 To find more information about a message, see the CLM Messages Information Center at
2014-04-28 09:29:08,160 CRJAZ1363I Loading the configuration from "file:conf/jts/".
2014-04-28 09:29:08,847 CRJAZ1779I This server is configured as a JTS.
2014-04-28 09:29:09,191 CRJAZ2558I Setting the local server rename state to false and the openServerDescriptionServiceTemporarily state to false.
2014-04-28 09:29:11,081 CRJAZ1365I The server is attempting to connect to the following database: "//nsrrepoj01:1433;databaseName=jts;user=xxxxxxxx;password=xxxxxxxx"
2014-04-28 09:29:11,550 CRJAZ2654E The server was unable to connect to the database because the database connection settings are invalid or because database is unreachable (SQLSTATE: S0001, SQLCODE: 18456). Verify the connection settings in your file. See the Jazz Team Server log for more information. Login failed for user 'jtsUser'. ClientConnectionId:acd9a5ba-88b4-4894-b49f-8cb107a2cbbe

Philippe Chevalier commented Apr 29 '14, 8:12 a.m.
I think you need to review the database, and the permission for the jts_user.  Please review the following site.   I pasted a quote that may be relevant to your situation but I would review all of the requirement and find out if there is an aspect that may be missing.

Setting up an SQL Server database

Quote:  from link above
For Windows operating system Ensure that your server security is in mixed mode. You can verify the mode by checking the server security. It should be set to SQL Server and Windows Authentication Mode.

permanent link
Ad Smeets (111) | answered Apr 29 '14, 10:12 a.m.
We managed to solve the issue by manually adding the correct password tot the file. I think something went wrong in the copy action as described in the log file. We will evaluate this issue later on. Thanks so far.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.