It's all about the answers!

Ask a question

Sometimes the Source control component under "Team Artifacts" is invisible in VS.


Ziv Rechnitser (91618) | asked Oct 14 '12, 7:15 a.m.
retagged Dec 16 '13, 5:51 p.m. by David Lafreniere (4.3k7)
 Hi All,

We are using RTC 3.0.1 with VS 2008 & 2010.
Sometimes the Source control component under "Team Artifacts"  is invisible.
We can try adding the Change Explorer window that sometimes show again the Source control but not all the time.
If the first solution doesn't work We need to reinstall the RTC client for VS.
Did anyone came across this issue?  

THX,

Comments
Norman Dignard commented Nov 22 '13, 9:54 a.m.

We jsut had the similar issue with  VS 2010 and RTC 4.0.3. The team artifacts view does not show the source control.  Did you resolve your problem and if so what what the fix?

2 answers



permanent link
Arne Bister (2.6k12532) | answered Dec 24 '12, 7:30 a.m.
JAZZ DEVELOPER
Hi,

leafing through older unanswered questions I came upon this one. With the retag the chances are higher that the RTC Visual Studio team will catch this.

Do you still have the issue? Is this happening under certain circumstances or with certain components?
It surely does not sound like expected behavior so if this persists, please do open a defect on jazz.net

- Arne

permanent link
Nancy Coelho (37) | answered Dec 16 '13, 7:10 p.m.
Please see the attached bitmap. If your setting  in the Visual Studio IDE   Tools>Options>Source Control is NOT set to Jazz Source Control then in Team Artifacts view - Source Control component is not visible. Once  it is set to "Jazz Source Control " and save it. That setting is saved in the registry. You should see an entry something like this in your Registry

[HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config\SourceControlProviders\{a2a26e11-f0af-4f12-a447-dcdbb6430f9b}]
@="Jazz Source Control"
"Service"="{a69d9113-a241-4239-9261-c3923cb03b97}"

[HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0_Config\SourceControlProviders\{a2a26e11-f0af-4f12-a447-dcdbb6430f9b}\Name]
@="#100"
"Package"="{ac8810c5-f6e7-4145-83aa-fdfff6f5506d}"

Jazz Source Control setting

Your answer


Register or to post your answer.