It's all about the answers!

Ask a question

Why should I kindly rerun the operation while doing a delivery?


Andy Jewell (24224868) | asked Dec 18 '13, 1:28 p.m.
retagged Dec 18 '13, 4:08 p.m. by David Lafreniere (4.3k7)
I hope I'm not just asking for an extra set of eyes here, but can anyone help explain why this is complaining?

C:\Users\>lscm status -d ".." -C
Workspace: (2172) "build fix dev o386600" <-> (2052) "Build Fix DEV"
  Component: (2132) "master"
    Baseline: (2644) 52 "1641121313-local"
    Outgoing:
      Change sets:
        (2652) *--@  3057 "Testing deliveries" - "Merges" 18-Dec-2013 08:23 AM
          Changes:
            ---c- \.jazzignore
            ---c- \build.gradle
            ---c- \buildSrc\mbe_instruction_template.xml
            ---c- \buildSrc\src\main\groovy\ArfMaker.groovy
            ---c- \buildSrc\src\main\groovy\CompareWtoS.groovy
            ---c- \buildSrc\src\main\groovy\RtcHandler.groovy
            --a-- \cmdline2.txt
            ---c- \gradle.properties
          Work items:
            (2560) 3057 "Testing deliveries"
    Baselines:
      (2644) 52 "1641121313-local"
  Component: (2256) "testbatch"
    Baseline: (2648) 5 "1644121313-local"
    Outgoing:
      Baselines:
        (2648) 5 "1644121313-local"
        (2598) 4 "1213-022914_localbuild"
  Component: (2255) "testmbestaging"
    Baseline: (2649) 9 "1644121313-local"
    Outgoing:
      Change sets:
        (2658) *--@  3057 "Testing deliveries" - "additional changes" 18-Dec-20>
          Changes:
            ---c- \day-one\sync_table_sequences.sql
            ---c- \db-objects\PKG_INT_T3_PUBTOMBE.sql
          Work items:
            (2560) 3057 "Testing deliveries"
    Baselines:
      (2649) 9 "1644121313-local"

Ok - so there are two changesets that I can see and both are related to the same work item 3057 (alias 2560).  Yet, when I try to deliver these, I get an error:

C:\Users\>lscm deliver -c 2658 2652
Problem running 'deliver':
Delivering change sets will cause a gap in the change history. Kindly rerun the operation ensuring that items
which are part of multiple change sets are run together.

Do I have to deliver a baseline, too, or am I overlooking something else??


If I try to deliver without the changeset selectors, then I get this:

C:\Users\>lscm deliver
Process Reports:
  Name: Deliver
  Operation Reports:
    Name: Source Control Operation
    Name: Deliver
    Participant Reports:
      Name: Require Work Items
        A work item must be associated with the change set.
Problem running 'deliver':
'Deliver' failed. Preconditions have not been met: A work item must be associated with the change set.

But again, from the status I don't see that there are any changes that aren't already in a changeset.


- Andy

One answer



permanent link
Andy Jewell (24224868) | answered Dec 18 '13, 7:52 p.m.
Part of the answer to this is that in the original status command, there was a changeset within the baseline.  This could be seen with:

lscm status -d ".." -C -B
	
So I had some lurking changesets.  Unfortunately, I could not seem to deliver either my changeset OR my embedded baseline/changeset through the commandline since it only accepts changesets OR baselines (e.g., you can put one type of selector and then use an option to declare if those selectors are changesets, changes, baselines, components, etc).  I tried putting the underlying changeset alias (the changeset within the baseline) but it told me it could not be resolved.  It may have worked had I found the UUIDs of the changesets and used those but instead I just delivered through the UI and that worked ok.

Comments
1
Shashikant Padur commented Dec 18 '13, 10:31 p.m.
JAZZ DEVELOPER

To deliver all the baselines/changesets you could have just run 'lscm deliver' (as you have shown in your last operation) once you have associated a workitem to the change set within the baseline.


Andy Jewell commented Dec 19 '13, 11:02 a.m.

True. . . at the time I hadn't yet discovered the secret -B option. . . :)

Your answer


Register or to post your answer.